Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 597005 - ksmtune: typo: MemCached -> Cached
ksmtune: typo: MemCached -> Cached
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Dan Kenigsberg
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-27 18:04 EDT by Dan Kenigsberg
Modified: 2010-11-10 13:55 EST (History)
4 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.70.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 03:19:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Kenigsberg 2010-05-27 18:04:51 EDT
Description of problem:
ksmtune does not take account of cached pages as it should due to a typo when reading /proc/meminfo

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.59.el6.x86_64

The fix is simple and accepted "upstream" 

Index: ksmtuned
===================================================================
RCS file: /cvs/dist/rpms/qemu-kvm/RHEL-6/ksmtuned,v
retrieving revision 1.2
diff -u -r1.2 ksmtuned
--- ksmtuned	6 Apr 2010 16:00:05 -0000	1.2
+++ ksmtuned	27 May 2010 22:02:14 -0000
@@ -75,7 +75,7 @@
 }
 
 free_memory () {
-    awk '/^(MemFree|Buffers|MemCached):/ {free += $2}; END {print free}' \
+    awk '/^(MemFree|Buffers|Cached):/ {free += $2}; END {print free}' \
                 /proc/meminfo
 }
Comment 1 RHEL Product and Program Management 2010-05-27 18:15:36 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 lihuang 2010-06-09 08:46:49 EDT
verified in qemu-kvm-0.12.1.2-2.71.el6
[root@t78 ~]# grep  -n Cached /usr/sbin/ksmtuned 
78:    awk '/^(MemFree|Buffers|Cached):/ {free += $2}; END {print free}' \
[root@t78 ~]# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.71.el6.x86_64

Note You need to log in before you can comment on or make changes to this bug.