Bug 59702 - kernel-2.4.9-21 ignores mem=xxM
Summary: kernel-2.4.9-21 ignores mem=xxM
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-11 21:39 UTC by Nick Uniatowski
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 20:19:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg from i686 test kernel. (14.84 KB, text/plain)
2002-02-13 15:11 UTC, Nick Uniatowski
no flags Details

Description Nick Uniatowski 2002-02-11 21:39:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.8) Gecko/20020204

Description of problem:
kernel-2.4.9-21 ignores append=" mem=320M" from lilo and mem=320M from lilo
prompt. This worked in the kernel-2.4.7 kernel and is required for my system
(Compaq Proliant 2500). Without it the system shows 14M RAM available.

Version-Release number of selected component (if applicable): 2.4.9-21 i686


How reproducible:
Always

Steps to Reproduce:
1.See Description
2.
3.
	

Additional info:

Comment 1 Arjan van de Ven 2002-02-12 09:17:55 UTC
Ok found the cause. I'll put a fixed kernel on my webstite soon for testing.

Comment 2 Arjan van de Ven 2002-02-13 13:43:06 UTC
Testkernel with fix is available at

http://people.redhat.com/arjanv/testkernels

Comment 3 Nick Uniatowski 2002-02-13 15:10:16 UTC
Tested and Working on i686. There were a bunch of "hm, page reserved twice" msgs
at boot. Dont know if this is a problem. I'll attach my dmesg output.

Note: required modutils-2.4.13. Used modutils-2.4.13-3.1.i386.rpm from rawhide.

Thanks.

Comment 4 Nick Uniatowski 2002-02-13 15:11:21 UTC
Created attachment 45539 [details]
dmesg from i686 test kernel.

Comment 5 Arjan van de Ven 2003-06-07 20:19:43 UTC
current errata kernels honor this flag fine


Note You need to log in before you can comment on or make changes to this bug.