Bug 597036 - Goddard theme missing on upgrade to F13
Goddard theme missing on upgrade to F13
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-27 20:47 EDT by Patrick O'Callaghan
Modified: 2010-05-28 20:10 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-28 18:05:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick O'Callaghan 2010-05-27 20:47:06 EDT
Description of problem:
Upgraded F12->F13. The Goddard theme rpm is missing, so KDM won't start.

Version-Release number of selected component (if applicable):


How reproducible:
Solid

Steps to Reproduce:
1.Upgrade existing F12 KDE installation to F13
2.Boot
3.Get no login screen and popup error about missing theme
  
Actual results:
Popup error on black screen

Expected results:
KDM login screen

Additional info:
Error message is:
Cannot open theme file /usr/share/kde4/apps/kdm/themes/Goddard.

I had to install it by hand. This pulled in goddard-backgrounds which was also missing.
Comment 1 Rex Dieter 2010-05-28 09:18:29 EDT
rpm -q kde-settings-kdm

please.

For me

$ rpm -q kde-settings-kdm
kde-settings-kdm-4.4-16.fc13.noarch

$ rpm -qR kde-settings-kdm | grep kdm
config(kde-settings-kdm) = 4.4-16.fc13
kdm  
system-kdm-theme

$ rpm -q --whatprovides system-kdm-theme
goddard-kde-theme-13.0.1-1.fc13.noarch


So, in theory, 
kde-settings-kdm-4.4-16 should pull in goddard-kde-theme
Comment 2 Rex Dieter 2010-05-28 09:18:53 EDT
may as well do both on your box:

rpm -q kde-settings-kdm

rpm -q --whatprovides system-kdm-theme
Comment 3 Patrick O'Callaghan 2010-05-28 09:49:25 EDT
[poc@bree:~] rpm -q kde-settings-kdm
kde-settings-kdm-4.4-16.fc13.noarch
[poc@bree:~] rpm -q --whatprovides system-kdm-theme
goddard-kde-theme-13.0.1-1.fc13.noarch

However this may be misleading as I immediately did a "yum upgrade" after installation. According to /root/upgrade.log, the packages installed by anaconda were:

[poc@bree:~] sudo cat /root/upgrade.log|egrep -i kdm\|goddard\|kde-settings
Upgrading goddard-backgrounds-single-13.0.0-1.fc13.noarch
Upgrading goddard-backgrounds-gnome-13.0.0-1.fc13.noarch
Upgrading kde-settings-4.4-16.fc13.noarch
Upgrading kde-settings-kdm-4.4-16.fc13.noarch
Upgrading kdm-4.4.2-5.fc13.x86_64
Upgrading kde-settings-pulseaudio-4.4-16.fc13.noarch

Note that there's no goddard-kde-theme
Comment 4 Rex Dieter 2010-05-28 10:01:53 EDT
OK, I'm stumped, not sure how or why the 
system-kdm-theme
dependency was seemingly not met on the upgrade.  Any ideas?
Comment 5 Patrick O'Callaghan 2010-05-28 10:53:18 EDT
Not really, but I did have some trouble with Anaconda (see https://bugzilla.redhat.com/show_bug.cgi?id=596387) so maybe it's related in some really obscure way. Luckily the rest of the upgrade seems to have worked OK.
Comment 6 Rex Dieter 2010-05-28 11:14:42 EDT
ok, I have a theory which goes like this:

in f12, 
constantine-kde-theme Provides: system-kdm-theme

and I'll go out on a limb that the f13 dvd doesn't include the newer build of constantine-kde-theme that does *not* provide that.

So, on upgrade, anaconda/yum decided goddard-kde-theme wasn't needed to satisfy the dep.

It would've been rectified the first time you did any sort of
yum update
(since a newer constantine-kde-theme would then get installed)


If this is all true, we'll have to account for this for future releases.  Options include

1.  back out of using the indirect
system-kdm-theme
dependency.  In this case, would mean we could've used
Requires: goddard-kde-theme
directly.

2.  work to make sure that f-1 (and possibly f-2) default *-kde-theme packages end up on the dvd
Comment 7 Rex Dieter 2010-05-28 11:47:47 EDT
or
1b.  use something specific to each release, but still generic-ish, something like
fedora13-kdm-theme ?
meh, not sure I like that either.
Comment 8 Patrick O'Callaghan 2010-05-28 13:31:52 EDT
This is what's on the F13 DVD as distributed:

[poc@bree:Torrents] ls /Repo/Packages/|egrep -i kdm\|goddard\|kde-settings
goddard-backgrounds-gnome-13.0.0-1.fc13.noarch.rpm
goddard-backgrounds-kde-13.0.0-1.fc13.noarch.rpm
goddard-backgrounds-single-13.0.0-1.fc13.noarch.rpm
goddard-kde-theme-13.0.1-1.fc13.noarch.rpm
kde-settings-4.4-16.fc13.noarch.rpm
kde-settings-kdm-4.4-16.fc13.noarch.rpm
kde-settings-pulseaudio-4.4-16.fc13.noarch.rpm
kdm-4.4.2-5.fc13.x86_64.rpm
Comment 9 Patrick O'Callaghan 2010-05-28 13:42:02 EDT
(In reply to comment #6)
> ok, I have a theory which goes like this:
> 
> in f12, 
> constantine-kde-theme Provides: system-kdm-theme
> 
> and I'll go out on a limb that the f13 dvd doesn't include the newer build of
> constantine-kde-theme that does *not* provide that.

The DVD doesn't include any version of constantine-* so that could be it:

$ ls /Repo/Packages/|grep -i constantine
$

So maybe the new theme for each version should obsolete the theme for the previous version. That would make sense.
Comment 10 Kevin Kofler 2010-05-28 14:18:28 EDT
Not really. You can still use the older themes on newer Fedora releases if you prefer (back to F9; the KDE 3 KDM themes are not compatible with KDE 4).
Comment 11 Patrick O'Callaghan 2010-05-28 14:56:55 EDT
If that's the case, why does the upgrade process require you to change the theme and then fail because the theme is not available? Some crossed wires here it seems.
Comment 12 Kevin Kofler 2010-05-28 17:02:04 EDT
This is due to how %config(noreplace) works. The default configuration changed, so if you haven't edited your kdmrc, you'll get the new default kdmrc with the new default theme.
Comment 13 Patrick O'Callaghan 2010-05-28 17:57:24 EDT
The end result of which is that kdmrc uses a theme which isn't installed. This is clearly wrong, but I'm no expert on KDE or Anaconda so I'm afraid someone else will have to think of the right way to avoid it.
Comment 14 Kevin Kofler 2010-05-28 18:05:01 EDT
There's no way to avoid it. The DVD cannot be respun now. We can just recommend not to upgrade using the DVD (which I have been doing all the time because it also doesn't include updates, so it's really broken by design).

You need to run "yum update" and you'll get the missing KDM theme. That's all we can do: Whatever update we push to "fix" this, you'd always need to run "yum update" to get it. So there's nothing we can do which isn't already done.

I guess the workaround (yum install goddard-kde-theme) can be documented. But other than that, this is a CANTFIX, sorry.
Comment 15 Patrick O'Callaghan 2010-05-28 20:10:19 EDT
Of course the DVD can't be undone. What can be done is make sure it doesn't happen next time, for F13->F14.

Note You need to log in before you can comment on or make changes to this bug.