Bug 597045 - [Beaker] Unable to return a system from the command line. reserve workflow
Summary: [Beaker] Unable to return a system from the command line. reserve workflow
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: beah (Show other bugs)
(Show other bugs)
Version: 0.5
Hardware: All Linux
medium
medium vote
Target Milestone: ---
Assignee: Marian Csontos
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-28 02:06 UTC by Jeff Burke
Modified: 2010-06-15 04:46 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-15 04:46:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Burke 2010-05-28 02:06:59 UTC
Description of problem:
 Using Beaker to reserve a system. https://beaker.engineering.redhat.com/reserveworkflow You are unable to return it using the return2rhts.sh

# return2rhts.sh 
Unable to connect to server, sleeping 5 seconds...
Unable to connect to server, sleeping 5 seconds...
Unable to connect to server, sleeping 5 seconds...
Unable to connect to server, sleeping 5 seconds...

]# cat `which return2rhts.sh`
#!/bin/sh
export RESULT_SERVER=localhost:7080
export TESTID=16758
/usr/bin/rhts-test-update localhost:7080 16758 finish
touch /var/cache/rhts/16758/done
/bin/echo Hit Return to reboot the system and continue any
/bin/echo remaining RHTS tests. Or hit CTRL-C now if this
/bin/echo is not desired.
read dummy
/usr/bin/rhts-reboot

Comment 1 Marian Csontos 2010-06-15 04:32:58 UTC
This looks like a local anomaly and works for me.

May be related to Bug 589904 where on abnormal termination harness did not recover after reboot. Have you seen any kernel panics or hard rebooted the machine?

If this bug is seen again, keep the system running and ping me please.
If not I will close the bug in a couple of weeks.

Collect some info - at least try "ps -elFH" or something similar

Notes:
* extendtesttime.sh will not work either.
* Do not reboot! It might start working...
* Though I do not like +1`s in discussions, do not forget to add them here.

Comment 2 Marian Csontos 2010-06-15 04:46:56 UTC
I had a look and https://beaker.engineering.redhat.com/logs/2010/80/1080/2073///console.log this really looks like the system was powered on/off...

I could not find appropriate records in system's history, but the system is marked as broken.

Everything leads to the problem I mentioned in prev.comment. Closing the bug.


Note You need to log in before you can comment on or make changes to this bug.