Bug 597101 - ValueError: zFCP device 0.0.a000 not found, not even in device ignore list.
ValueError: zFCP device 0.0.a000 not found, not even in device ignore list.
Status: CLOSED DUPLICATE of bug 598087
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
s390x Linux
medium Severity medium
: rc
: ---
Assigned To: David Cantrell
Release Test Team
anaconda_trace_hash:7aec59fb998572d5b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-28 02:29 EDT by Jan Stodola
Modified: 2010-06-02 12:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-02 12:06:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2010-05-28 02:29:14 EDT
The following was filed automatically by anaconda:
anaconda 13.21.48 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/zfcp.py", line 134, in onlineDevice
    %(self.devnum,))
  File "/usr/lib/anaconda/storage/zfcp.py", line 368, in addFCP
    if d.onlineDevice():
  File "/usr/lib/anaconda/storage/zfcp.py", line 357, in readConfig
    self.addFCP(fields[0], fields[1], fields[2])
  File "/usr/lib/anaconda/storage/zfcp.py", line 388, in startup
    self.readConfig()
  File "/usr/lib/anaconda/iw/filter_gui.py", line 559, in getScreen
    storage.zfcp.ZFCP().startup()
  File "/usr/lib/anaconda/gui.py", line 1415, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib/anaconda/gui.py", line 1336, in nextClicked
    self.setScreen ()
ValueError: zFCP device 0.0.a000 not found, not even in device ignore list.
Comment 2 Jan Stodola 2010-05-28 02:37:08 EDT
Steps to reproduce:

CMS config file contains:
...
FCP_1="0.0.A000 0x50050763050B073D 0x4020400100000000"
...

If I detach device A000 from z/VM guest (#cp detach a000) and start new installation, traceback appears after selecting "Specialized Storage Devices" and clicking on Next button.
Comment 3 RHEL Product and Program Management 2010-05-28 02:55:29 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Steffen Maier 2010-06-01 18:01:42 EDT
I think that's a dup of bug 598087.
Comment 5 David Cantrell 2010-06-02 12:06:24 EDT

*** This bug has been marked as a duplicate of bug 598087 ***

Note You need to log in before you can comment on or make changes to this bug.