Bug 597169 - [abrt] crash in audacious-2.2-14.fc12: raise: Process /usr/bin/audacious2 was killed by signal 6 (SIGABRT)
Summary: [abrt] crash in audacious-2.2-14.fc12: raise: Process /usr/bin/audacious2 was...
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: audacious   
(Show other bugs)
Version: 12
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Michael Schwendt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f8b26581ca11fd04d6c17163679...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-28 10:02 UTC by Jiannan Liu
Modified: 2010-05-28 10:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-28 10:31:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (38.02 KB, text/plain)
2010-05-28 10:02 UTC, Jiannan Liu
no flags Details

Description Jiannan Liu 2010-05-28 10:02:33 UTC
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: audacious2
component: audacious
crash_function: raise
executable: /usr/bin/audacious2
global_uuid: f8b26581ca11fd04d6c17163679475de9dae181c
kernel: 2.6.32.9-70.fc12.i686.PAE
package: audacious-2.2-14.fc12
rating: 4
reason: Process /usr/bin/audacious2 was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

Comment 1 Jiannan Liu 2010-05-28 10:02:40 UTC
Created attachment 417544 [details]
File: backtrace

Comment 2 Michael Schwendt 2010-05-28 10:31:15 UTC
> audacious2: pcm.c:1942: snd_pcm_bytes_to_frames: Assertion `pcm' failed.\n

alsa-lib gave up here upon running into pcm=0x0.

As why the call trace from  MP3 decoder -> ALSA Gapless plugin -> alsa-lib  ended up like that cannot be seen.

> #4  0x06033bae in snd_pcm_bytes_to_frames (pcm=0x0, bytes=9216) at pcm.c:1942
>         __PRETTY_FUNCTION__ = "snd_pcm_bytes_to_frames"
>         __FUNCTION__ = "snd_pcm_bytes_to_frames"
> #5  0x00fe7eb4 in alsa_write_audio (data=0xb510a3a8, length=9216)
>     at alsa.c:455
>         writable = 9216
> #6  0x08059477 in output_pass_audio (playback=0x9491ee8, fmt=FMT_FLOAT, 
>     channels=2, size=9216, data=0xb5107fa8, going=0x0) at output.c:581
>         ready = 2304
>         samples = 2304
>         allocated = 0xb5107fa8
>         time = 1
> #7  0x006dc4f3 in write_output (arg=<value optimized out>) at decoder.c:56


Although the 'ALSA Gapless Output Plugin' in Audacious should work, please do prefer the 'Pulse Audio Output Plugin', especially since Fedora uses Pulse Audio by default and you haven't disabled it.


Note You need to log in before you can comment on or make changes to this bug.