Bug 597263 - Bring focus on "Yes, Continue" button - TUI rhn_register
Bring focus on "Yes, Continue" button - TUI rhn_register
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Jan Pazdziora
Garik Khachikyan
:
Depends On:
Blocks: 582655
  Show dependency treegraph
 
Reported: 2010-05-28 10:22 EDT by Garik Khachikyan
Modified: 2015-01-04 16:57 EST (History)
2 users (show)

See Also:
Fixed In Version: rhn-client-tools-1.0.0-16.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:30:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garik Khachikyan 2010-05-28 10:22:05 EDT
Description of problem:
there would be nice to see the focus on "Yes, Continue" button for "rhn_register --nox" when it lunches for a system being already registered (on the first window page)

It's actually a compatibility issue with my just-developing dogtail test which fails now on RHEL6 that runs okey on RHEL5

Version-Release number of selected component (if applicable):
rhn-client-tools-1.0.0-14.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:
the focus is set on the scrollbar comonent, so "Enter" action does not shift to the next page (as it was doing on RHEL5)

Expected results:
Make it possible by hitting "Enter" continue to the next page.

Additional info:
Comment 2 Jan Pazdziora 2010-05-28 10:24:29 EDT
Fixed in Spacewalk master, 66a66f5122bfb5f9780ecff24b611af6c029f3ef.
Comment 3 Jan Pazdziora 2010-05-28 10:26:29 EDT
Umm, taking.
Comment 4 RHEL Product and Program Management 2010-05-28 10:35:30 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 Jan Pazdziora 2010-05-28 11:07:20 EDT
Cherry picked to CLIENT-RHEL-6, commit dec949e7fd8fd3421acba5f7ec0b2ffb17265cc1.

Tagged and built as rhn-client-tools-1.0.0-16.el6.
Comment 8 Garik Khachikyan 2010-07-08 10:37:30 EDT
# VERIFIED

Checked the scenario in bug description: the issue is fixed.

Verified against package(s):
rhn-setup-1.0.0-24.el6.noarch
rhn-client-tools-1.0.0-24.el6.noarch
Comment 10 releng-rhel@redhat.com 2010-11-10 16:30:06 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.