Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 597372 - locking issues when attempting cmirror creation
locking issues when attempting cmirror creation
Status: CLOSED DUPLICATE of bug 568137
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.0
All Linux
high Severity urgent
: rc
: ---
Assigned To: Jonathan Earl Brassow
Corey Marthaler
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-28 14:33 EDT by Corey Marthaler
Modified: 2010-06-18 14:07 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-18 14:07:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lvcreate -vvvv from taft-01 (30.06 KB, text/plain)
2010-05-28 14:37 EDT, Corey Marthaler
no flags Details

  None (edit)
Description Corey Marthaler 2010-05-28 14:33:20 EDT
Description of problem:
I'll attach the -vvvv output as well.

[root@taft-01 tmp]# lvcreate -m 1 -n taft-01.10387 -L 500M lock_stress
  Error locking on node taft-02: Volume group for uuid not found: pBzCZ62cwyEYnQ6281HMVtfHtA8JZOBulM8ajlF3cWdHdsf0FhER1Upg533y0TPs
  Error locking on node taft-04: Volume group for uuid not found: pBzCZ62cwyEYnQ6281HMVtfHtA8JZOBulM8ajlF3cWdHdsf0FhER1Upg533y0TPs
  Error locking on node taft-03: Volume group for uuid not found: pBzCZ62cwyEYnQ6281HMVtfHtA8JZOBulM8ajlF3cWdHdsf0FhER1Upg533y0TPs
  Error locking on node taft-01: Volume group for uuid not found: pBzCZ62cwyEYnQ6281HMVtfHtA8JZOBulM8ajlF3cWdHdsf0FhER1Upg533y0TPs
  Aborting. Failed to activate mirror log.
  Failed to initialise mirror log.

[root@taft-01 tmp]# cman_tool nodes
Node  Sts   Inc   Joined               Name
   1   M    232   2010-05-27 22:02:27  taft-01
   2   M    232   2010-05-27 22:02:27  taft-02
   3   M    232   2010-05-27 22:02:27  taft-03
   4   M    232   2010-05-27 22:02:27  taft-04
[root@taft-01 tmp]# cman_tool services
fence domain
member count  4
victim count  0
victim now    0
master nodeid 3
wait state    none
members       1 2 3 4 

dlm lockspaces
name          clvmd
id            0x4104eefa
flags         0x00000000 
change        member 4 joined 1 remove 0 failed 0 seq 1,1
members       1 2 3 4 

[root@taft-01 tmp]# service cmirrord status
cmirrord (pid  2142) is running...
cmirror is running.

[root@taft-02 ~]# cman_tool nodes
Node  Sts   Inc   Joined               Name
   1   M    232   2010-05-27 17:00:52  taft-01
   2   M    224   2010-05-27 17:00:52  taft-02
   3   M    224   2010-05-27 17:00:52  taft-03
   4   M    228   2010-05-27 17:00:52  taft-04
[root@taft-02 ~]# cman_tool services
fence domain
member count  4
victim count  0
victim now    0
master nodeid 3
wait state    none
members       1 2 3 4 

dlm lockspaces
name          clvmd
id            0x4104eefa
flags         0x00000000 
change        member 4 joined 1 remove 0 failed 0 seq 3,4
members       1 2 3 4 

[root@taft-02 ~]# service cmirrord status
cmirrord (pid  2150) is running...
cmirror is running.

[root@taft-03 ~]# cman_tool nodes
Node  Sts   Inc   Joined               Name
   1   M    232   2010-05-27 17:01:48  taft-01
   2   M    224   2010-05-27 17:01:48  taft-02
   3   M    220   2010-05-27 17:01:48  taft-03
   4   M    228   2010-05-27 17:01:48  taft-04
[root@taft-03 ~]# cman_tool services
fence domain
member count  4
victim count  0
victim now    0
master nodeid 3
wait state    none
members       1 2 3 4 

dlm lockspaces
name          clvmd
id            0x4104eefa
flags         0x00000000 
change        member 4 joined 1 remove 0 failed 0 seq 2,3
members       1 2 3 4 

[root@taft-03 ~]# service cmirrord status
cmirrord (pid  2151) is running...
cmirror is running.

[root@taft-04 ~]# cman_tool nodes
Node  Sts   Inc   Joined               Name
   1   M    232   2010-05-27 22:02:27  taft-01
   2   M    228   2010-05-27 22:02:27  taft-02
   3   M    228   2010-05-27 22:02:27  taft-03
   4   M    228   2010-05-27 22:02:27  taft-04
[root@taft-04 ~]# cman_tool services
fence domain
member count  4
victim count  0
victim now    0
master nodeid 3
wait state    none
members       1 2 3 4 

dlm lockspaces
name          clvmd
id            0x4104eefa
flags         0x00000000 
change        member 4 joined 1 remove 0 failed 0 seq 1,2
members       1 2 3 4 

[root@taft-04 ~]# service cmirrord status
cmirrord (pid  2061) is running...
cmirror is running.


Version-Release number of selected component (if applicable):
2.6.32-28.el6bz590851_v1.x86_64

lvm2-2.02.65-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010
lvm2-libs-2.02.65-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010
lvm2-cluster-2.02.65-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010
device-mapper-1.02.48-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010
device-mapper-libs-1.02.48-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010
device-mapper-event-1.02.48-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010
device-mapper-event-libs-1.02.48-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010
cmirror-2.02.65-1.el6    BUILT: Wed May 19 11:19:57 CDT 2010


How reproducible:
Often
Comment 1 Corey Marthaler 2010-05-28 14:37:29 EDT
Created attachment 417718 [details]
lvcreate -vvvv from taft-01
Comment 2 Corey Marthaler 2010-06-02 15:25:14 EDT
This is in the latest as well.

[root@taft-04 ~]# lvcreate -m 1 -n mirror -L 100M taft
  Error locking on node taft-01: device-mapper: create ioctl failed: Device or resource busy
  Error locking on node taft-04: device-mapper: create ioctl failed: Device or resource busy
  Error locking on node taft-03: device-mapper: create ioctl failed: Device or resource busy
  Error locking on node taft-02: device-mapper: create ioctl failed: Device or resource busy
  Aborting. Failed to activate mirror log.
  Failed to initialise mirror log.
[root@taft-04 ~]# /usr/tests/sts-rhel6.0/lvm2/bin/lvm_rpms 
2.6.32-25.el6.x86_64

lvm2-2.02.66-3.el6    BUILT: Tue Jun  1 07:38:22 CDT 2010
lvm2-libs-2.02.66-3.el6    BUILT: Tue Jun  1 07:38:22 CDT 2010
lvm2-cluster-2.02.66-3.el6    BUILT: Tue Jun  1 07:38:22 CDT 2010
device-mapper-1.02.48-3.el6    BUILT: Tue Jun  1 07:38:22 CDT 2010
device-mapper-libs-1.02.48-3.el6    BUILT: Tue Jun  1 07:38:22 CDT 2010
device-mapper-event-1.02.48-3.el6    BUILT: Tue Jun  1 07:38:22 CDT 2010
device-mapper-event-libs-1.02.48-3.el6    BUILT: Tue Jun  1 07:38:22 CDT 2010
cmirror-2.02.66-3.el6    BUILT: Tue Jun  1 07:38:22 CDT 2010
Comment 4 Jonathan Earl Brassow 2010-06-17 18:22:13 EDT
corey, is this the same as 568137?  This bug shows the CLI output, and 568137 shows the log output?
Comment 5 Corey Marthaler 2010-06-18 14:07:13 EDT
Jon, I think you're right, this is probably a dup.

*** This bug has been marked as a duplicate of bug 568137 ***

Note You need to log in before you can comment on or make changes to this bug.