Bug 59741 - Build broken with bash-completion-2.05a-7
Build broken with bash-completion-2.05a-7
Product: Red Hat Linux
Classification: Retired
Component: libtiff (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Depends On:
  Show dependency treegraph
Reported: 2002-02-12 10:11 EST by Enrico Scholz
Modified: 2015-03-04 20:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-02-25 10:40:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-02-12 10:11:29 EST
Description of Problem:

| $ rpm --rebuild libtiff-3.5.5-14.src.rpm
| ...
| /var/volatile/rpm/BUILD/tiff-v3.5.5/man/apps
| make[2]: Entering directory `/var/volatile/rpm/BUILD/tiff-v3.5.5/man/apps'
| Makefile:1: *** missing separator.  Stop.
| make[2]: Leaving directory `/var/volatile/rpm/BUILD/tiff-v3.5.5/man/apps'
| make[1]: *** [install] Error 2

This is caused by recent bash-package which sets 'CDPATH=./[...]'. Therefore,
cd's into  a subdirectory will produce an output accordingly SUSv2:

| $ cd /usr/src/redhat/BUILD/tiff-v3.5.5/man
| $ cd apps
| /usr/src/redhat/BUILD/tiff-v3.5.5/man/apps
| $

The man/Makefile of libtiff contains a similar statement:

| apps/Makefile:
| ...
| (cd apps; echo 'install:' ... ) >apps/Makefile

Therefore, the full directory of .../man/apps will be the first line in
apps/Makefile and not the wanted 'install:'

The simplest way to prevent this, will be an 

| unset CDPATH

in the %build section of the spec-file.

Version-Release number of selected component (if applicable):

Comment 1 Phil Knirsch 2002-02-25 09:15:29 EST
I just tried to rebuild the rawhide version of libtiff-3.5.7-1 with bash-2.05a-8
and that worked without problems.

I'll close it as WORKSFORME for now. If you could check if you still get the
problem with these versions i'd really appreciate it.

Read ya, Phil
Comment 2 Enrico Scholz 2002-02-25 09:42:14 EST
My error; not bash itself but bash-completion-2.05a sets the CDPATH. I will
change summary accordingly.

Have you tried to build it with this package? (don't forget to relogin because
this env-variable will be set by login-shells only).
Comment 3 Phil Knirsch 2002-02-25 10:40:33 EST
True, now it fails for me as well... Will change in the specfile and update.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.