Bug 597422 - Xorg does not start on bootup
Summary: Xorg does not start on bootup
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-radeonhd   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Hans Ulrich Niedermann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-28 21:35 UTC by Dan Book
Modified: 2010-06-04 10:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-04 10:47:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg's startup log (59.88 KB, application/octet-stream)
2010-05-28 21:35 UTC, Dan Book
no flags Details

Description Dan Book 2010-05-28 21:35:47 UTC
Created attachment 417751 [details]
Xorg's startup log

Description of problem:
Booting up Fedora 13, X does not start and I am brought to the text-based login. Upon logging in, startx starts it up fine. Graphics card is a Radeon HD 4650, xorg.conf is set to use the radeonhd driver.

Here is my grub.conf entry (hasn't been manually changed):
title Fedora (2.6.33.4-95.fc13.x86_64)
	root (hd0,2)
	kernel /vmlinuz-2.6.33.4-95.fc13.x86_64 ro root=UUID=a64088fb-d59e-4eb7-8643-f77b440a211d nomodeset radeon.modeset=0 LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.8.0-12.fc13.x86_64
xorg-x11-drv-radeonhd-1.3.0-5.4.20100210git.fc13.x86_64

How reproducible:
Every bootup

Steps to Reproduce:
1. Install F13
2. Boot
  
Actual results:
Text login

Expected results:
Graphical login

Additional info:
Previously with Fedora 12 and possibly earlier releases, the rhgb option has led to the same text loading bar I am seeing now, as opposed to the graphical boot I see on my other computer. However, the graphical login started up afterward.
Let me know if any other logs would help.

Comment 1 Dan Book 2010-06-04 10:47:50 UTC
Well it turns out I'm dumb, I merged the changes from an /etc/inittab.rpmnew which apparently sets the init runlevel to 3 instead of the previous 5. Why a new RPM would create an rpmnew with runlevel 3 is another matter.


Note You need to log in before you can comment on or make changes to this bug.