Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 597457 - gdm does not offer "default" or "failsafe" sessions
gdm does not offer "default" or "failsafe" sessions
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: jmccann
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-28 21:35 EDT by Quentin Barnes
Modified: 2015-01-14 18:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-07 13:56:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Quentin Barnes 2010-05-28 21:35:54 EDT
Description of problem:
At the gdm login screen after selecting a login account, down at
the bottom bar it presents possible sessions in a "Sessions" box.
Only two are presented, "GNOME" and "KDE".  Under RHEL5, "Default
System Session", "Failsafe terminal", and "Last session" were also
available.

In my environment, I have my ~/.dmrc file's "Session" variable
set to "default" because I run my own X login session.  With
RHEL6, it will not let me have this session and upon loggin in
will overwrite my ~/.dmrc file with "gnome".

Version-Release number of selected component (if applicable):
gdm-2.28.2-5.el6.x86_64

How reproducible:
100%


Steps to Reproduce:
1. Go to gdm login screen and select an account
2. Click on "Sessions" box at bottom of screen.
3.
  
Actual results:
Just "KDE" and "GNOME" are presented.

Expected results:
To be able to at least have "Default System Session" and "Failsafe
terminal", and "Last session" as with RHEL5 systems.

Additional info:
I worked around this gdm limitation by copying the file
/usr/share/gdm/BuiltInSessions/default.desktop from a RHEL5 file
system to same place on the RHEL6 file system.  Now I can at
least select "Default System Session" from gdm now and it
does the right thing -- "default" is passed as argument 1 to
/etc/X11/xinit/Xsession when it is started.

I don't know why default.desktop is missing from RHEL6. if under
this version of gdm there's a new way or different way now to select
or present "Default System Session" that I just don't know about,
please let me know.
Comment 2 RHEL Product and Program Management 2010-06-07 12:07:50 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 jmccann 2010-06-07 13:56:10 EDT
This functionality, with the exception of Failsafe, is now provided by the xorg-x11-xinit-session package.  For Failsafe you can create a new desktop file to provide such a session.
Comment 4 Quentin Barnes 2010-06-07 14:13:36 EDT
Ah, the xorg-x11-xinit-session RPM is not part of the RHEL6 Beta release.  For a "Beta" release, it's not very functionally complete dropping hundreds of RPMs.

I hope Red Hat considers adding a package to restore the failsafe functionality.  It's used very infrequently, but is very helpful when it is needed.

Note You need to log in before you can comment on or make changes to this bug.