Bug 597514 - parted-2.3 is available
parted-2.3 is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-29 06:16 EDT by Upstream Release Monitoring
Modified: 2010-07-29 14:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-26 03:04:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2010-05-29 06:16:09 EDT
Latest upstream release: 2.3
Current version in Fedora Rawhide: 2.2
URL: http://ftp.gnu.org/gnu/parted/

Please consult the package update guidelines before you issue an update to a stable branch: https://fedoraproject.org/wiki/Package_update_guidelines

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_Release_Monitoring
Comment 1 Richard Shaw 2010-07-25 16:41:42 EDT
Would it be possible to get a 2.3 version in at least F13 updates-testing? I've been bitten by the resize bug[1] and have had other problems with the current version supplied in the repo.

[1] http://gparted-forum.surf4.info/viewtopic.php?id=13777
Comment 2 Hans de Goede 2010-07-26 03:04:52 EDT
Current rawhide already contains 2.3 -> closing.

(In reply to comment #1)
> Would it be possible to get a 2.3 version in at least F13 updates-testing? I've
> been bitten by the resize bug[1] and have had other problems with the current
> version supplied in the repo.
> 
> [1] http://gparted-forum.surf4.info/viewtopic.php?id=13777    

I'm afraid that is not possible as the soname of libparted has changed, you can download the rawhide version, that should work on F-13 too:
http://koji.fedoraproject.org/koji/buildinfo?buildID=184653

Note that you will need to un-install gparted or also update gparted to the rawhide version (no guarantees that will work).
Comment 3 Richard Shaw 2010-07-26 09:11:13 EDT
I updated to the rawhide version and verified it loads fine. I haven't tried to manipulate anything yet. On a side note, I no longer see the terminal output about it complaining about the kernel not being able to re-read the partition table.

Thanks!
Comment 4 Richard Shaw 2010-07-29 14:05:16 EDT
Well, ran into a major problem with the rawhide packages. My system is no longer bootable. I'm assuming is has something to do with one of the other packages that got updated along with parted. Perhaps dev-mapper or something like that? 

When booting LVM finds all of my logical volumes. I have one VG with 3 LVs ('root', 'var', an 'swap') and a second whole disk VG with one LV ('home').

Then when trying to check the volumes is bombs out on /dev/mapper/vg-hobbes-lv-root which of course is my root partition. I give the root password as it requests but I can not run ANY of the LVM programs, I'm assuming something it needs isn't loaded yet.

What is very strange is two of my four LVs are mounted in /dev/mapper/...

Booting Systems Rescue CD all LVs are accessible and clean.

I'm going to try to boot a liveCD tonight and chroot to my '/' and see if I can rpm out the rawhide packages and replace them with the F13 packages.

Any hints would be welcomed.

Note You need to log in before you can comment on or make changes to this bug.