Bug 597519 - virt-manager: destructive pool building (lvm, disk) is broken
Summary: virt-manager: destructive pool building (lvm, disk) is broken
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
: 598359 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-29 11:18 UTC by Justin Clift
Modified: 2010-11-10 21:53 UTC (History)
4 users (show)

Fixed In Version: virt-manager-0.8.4-5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 21:53:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot 1 - First page of wizard for adding new storage pool (29.41 KB, image/png)
2010-05-29 11:18 UTC, Justin Clift
no flags Details
Screenshot 2 - Second page of wizard for adding new storage pool. This one shows the Format option and the Build Pool checkbox. (34.80 KB, image/png)
2010-05-29 11:19 UTC, Justin Clift
no flags Details
Screenshot 3 - Warning dialog showing that the device will be formatted. (this is not the error) (12.23 KB, image/png)
2010-05-29 11:20 UTC, Justin Clift
no flags Details
Screenshot 4 - The error dialog showing the error. (33.18 KB, image/png)
2010-05-29 11:23 UTC, Justin Clift
no flags Details

Description Justin Clift 2010-05-29 11:18:37 UTC
Created attachment 417838 [details]
Screenshot 1 - First page of wizard for adding new storage pool

Description of problem:

Creation of dedicated local "disk" type storage pools with the storage pool wizard fails, if the disk in question has no disk label.  (ie brand new or has been wiped)


Version-Release number of selected component (if applicable):

# rpm -qa | grep virt-manager
virt-manager-0.8.2-3.el6.noarch
#


How reproducible:

Every time.


Steps to Reproduce:
1. Physically connect a new disk device to the host server.
2. Start the Virtual Machine Manager GUI on the host server, then open the host properties dialog and choose the Storage tab.
3. Create a new "disk" storage pool, specifying the newly attached disk, and specifying a format (ie "dos").  This is shown in screenshots 1 to 3.

The error occurs immediately upon pressing the Finish button, as virt-manager attempts to create the storage pool.  Perhaps virt-manager isn't passing the options to libvirt correctly?


Actual results:

The Storage Pool is not created.  Instead, an error message dialog appears (screenshot 4), claiming a disk format (ie "dos") must be specified, even though this was done.  (see screenshot 2 as evidence of options passed)


Expected results:

Storage pool to be created and usable as per options given.


Additional info:

Even if a disk label is created on the newly attached disk prior to running the storage pool wizard, this (exact) error still occurs.

i.e:

# parted /dev/sdb
GNU Parted 2.1
Using /dev/sdb
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) mklabel                                                          
New disk label type? msdos
(parted) q                                                                
Information: You may need to update /etc/fstab.                           

#

The only workaround this far to getting the pool created, is by unchecking the "Build Pool" checkbox in the wizard.  This allows the storage pool wizard to finish, with the storage pool becoming available and "active" in the storage pools tab.

However, volumes created within this storage pool do not become visible until the virt-manager GUI is then restarted (another bug).

Comment 1 Justin Clift 2010-05-29 11:19:41 UTC
Created attachment 417839 [details]
Screenshot 2 - Second page of wizard for adding new storage pool.  This one shows the Format option and the Build Pool checkbox.

Comment 2 Justin Clift 2010-05-29 11:20:43 UTC
Created attachment 417842 [details]
Screenshot 3 - Warning dialog showing that the device will be formatted.  (this is not the error)

Comment 3 Justin Clift 2010-05-29 11:23:13 UTC
Created attachment 417843 [details]
Screenshot 4 - The error dialog showing the error.

Comment 5 RHEL Product and Program Management 2010-06-07 16:13:09 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 6 Cole Robinson 2010-06-14 17:39:31 UTC
Thanks for the report. The 'are you sure' prompt when selecting the 'build' option was conspiring behind the scenes to break pool creation. Trying to build a disk or LVM pool was broken. Fixed upstream now:

http://hg.fedorahosted.org/hg/virt-manager/rev/d23b35a17efc

Comment 7 Cole Robinson 2010-06-14 18:03:29 UTC
*** Bug 598359 has been marked as a duplicate of this bug. ***

Comment 9 dyuan 2010-07-06 02:18:27 UTC
Verified PASSED with virt-manager-0.8.4-6.el6.

Comment 10 releng-rhel@redhat.com 2010-11-10 21:53:54 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.