Bug 597546 - [abrt] crash in firefox-3.6.3-4.fc13: Process /usr/lib64/firefox-3.6/firefox was killed by signal 6 (SIGABRT)
Summary: [abrt] crash in firefox-3.6.3-4.fc13: Process /usr/lib64/firefox-3.6/firefox ...
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:40ae8cfadf83d9be5d469bff2bf...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-29 13:47 UTC by Alan Topham
Modified: 2010-06-13 17:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-13 17:21:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (73.08 KB, text/plain)
2010-05-29 13:47 UTC, Alan Topham
no flags Details

Description Alan Topham 2010-05-29 13:47:47 UTC
abrt 1.1.0 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/firefox-3.6/firefox -UILocale en-GB
component: firefox
crash_function: nsProfileLock::FatalSignalHandler
executable: /usr/lib64/firefox-3.6/firefox
global_uuid: 40ae8cfadf83d9be5d469bff2bf5f5c6f28e4611
kernel: 2.6.33.4-95.fc13.x86_64
package: firefox-3.6.3-4.fc13
rating: 4
reason: Process /usr/lib64/firefox-3.6/firefox was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)

Comment 1 Alan Topham 2010-05-29 13:47:50 UTC
Created attachment 417862 [details]
File: backtrace

Comment 2 Chris Campbell 2010-06-13 17:20:24 UTC
#2  <signal handler called>
No symbol table info available.
#3  0x00007f47c10ab9c5 in raise (sig=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
        resultvar = 0
        pid = 4821
        selftid = 4821
#4  0x00007f47c10ad1a5 in abort () at abort.c:92
        save_stage = 2
        act = warning: can't find linker symbol for virtual table for `(null)' value
{__sigaction_handler = {sa_handler = 0x7f47c13f2d78 <stderr>, 
            sa_sigaction = 0x7f47c13f2d78 <stderr>}, sa_mask = {__val = {
    2048, 1024, 139945368461600, 139945297106048, 4246450, 139946157931344, 
    139946179037584, 139944959330304, 4294967295, 1, 5, 3123088, 0, 
    140736540160112, 0, 139946083000320}}, sa_flags = -1037365504, 
          sa_restorer = 0x7f4700000005}
        sigs = {__val = {32, 0 <repeats 15 times>}}
#5  0x00007f47bc96bea4 in IA__g_assertion_message (
    domain=<value optimized out>, file=<value optimized out>, 
    line=<value optimized out>, func=
    0x7f479b08e800 "swfdec_resource_stream_target_open", message=
    0x7f478db8d3e0 "assertion failed: (movie)") at gtestutils.c:1318
        lstr = 
    "216\000\377\177\000\000\230\060\221\274G\177\000\000p\304\256\205G\177\000\000\245\270\b\233G\177\000"
        s = 
    0x7f4791f9a120 "Swfdec:ERROR:swfdec_resource.c:216:swfdec_resource_stream_target_open: assertion failed: (movie)"
#6  0x00007f47bc96c450 in IA__g_assertion_message_expr (domain=
    0x7f479b0720ca "Swfdec", file=0x7f479b08e20b "swfdec_resource.c", line=
    216, func=0x7f479b08e800 "swfdec_resource_stream_target_open", 
    expr=<value optimized out>) at gtestutils.c:1329
        s = 0x0
#7  0x00007f479b03ea9f in swfdec_resource_stream_target_open (
    target=<value optimized out>, stream=<value optimized out>)
    at swfdec_resource.c:216
        object = <value optimized out>
        movie = 0x0
        query = <value optimized out>
        __PRETTY_FUNCTION__ = "swfdec_resource_stream_target_open"
#8  0x00007f479b04b3e3 in swfdec_stream_process (streamp=0x7f478fbc3430, 
    unused=<value optimized out>) at swfdec_stream.c:213
        priv = 0x7f478fbc3490
        __PRETTY_FUNCTION__ = "swfdec_stream_process"
#9  0x00007f479b035557 in swfdec_player_perform_external_actions (player=
    0x7f47785a1800 [SwfmozPlayer]) at swfdec_player.c:559
        priv = 0x7f47785a1960
        i = <value optimized out>
        __PRETTY_FUNCTION__ = "swfdec_player_perform_external_actions"
#10 0x00007f479b036e18 in swfdec_player_iterate (
    timeout=<value optimized out>) at swfdec_player.c:1760
        priv = 0x7f47785a1960
        player = 0x7f47785a1800 [SwfmozPlayer]
        walk = <value optimized out>
        __PRETTY_FUNCTION__ = "swfdec_player_iterate"



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Chris Campbell 2010-06-13 17:21:56 UTC
Thank you for taking the time to make this bug report.

Unfortunately, crash here happened in the swfdec flash player. While this is an open source solution for Flash, it is no longer supported nor is it included in Fedora 13 or newer builds.

Closing as CANTFIX (because that's our situation)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.