Bug 59759 - C++ header missing
Summary: C++ header missing
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: db4 (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-12 20:13 UTC by Enrico Scholz
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-13 23:01:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2002-02-12 20:13:30 UTC
Description of Problem:

Using the C++ interface of db4 is impossible since the needed headers are missing:

| $ echo '#include <db_cxx.h>' >test.cc
| $ g++ -I /usr/include/db4 test.cc 
| In file included from test.cc:1:
| /usr/include/db4/db_cxx.h:64:24: cxx_common.h: No such file or directory
| /usr/include/db4/db_cxx.h:65:24: cxx_except.h: No such file or directory
| In file included from test.cc:1:
| /usr/include/db4/db_cxx.h:159: syntax error before `{' token
| ...

While building the package, these two files (cxx_common.h and cxx_except.h) are
installed, but will be omitted because they are not listed in the %files-section.


Version-Release number of selected component (if applicable):

db4-4.0.14-2

Comment 1 Jeff Johnson 2002-02-24 17:20:04 UTC
Some recent version of db4 has this fixed, but I dunno what
package is current anymore.

Comment 2 Jay Turner 2002-03-19 21:45:18 UTC
Is this still an issue with Beta 2?

Comment 3 Enrico Scholz 2002-03-19 22:29:51 UTC
Because db4 was abandoned in beta2 and the new/old db[123] packages do not use
these files: no.

But when reviving db4, the problem will reappear...

Comment 4 Enrico Scholz 2002-05-31 18:34:51 UTC
As prophesied, problem revives in rawhide...

Comment 5 Jeff Johnson 2004-11-13 23:01:03 UTC
/usr/include/db4/db_cxx.h is in db4-devel-4.3.21-1 and db4-4.2.52-6

/usr/include/db4/{db_cxx.h,cxx_common.h,cxx_except.h} are in db4-4.1.25-8.

That should be more than enough to call this problem WORKSFORME,
2 years later.






Note You need to log in before you can comment on or make changes to this bug.