Bug 597630 - Cannot unlock gnome-screensaver (dialog does not appear)
Summary: Cannot unlock gnome-screensaver (dialog does not appear)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
low
high
Target Milestone: ---
Assignee: jmccann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-29 21:46 UTC by Gerald Pfeifer
Modified: 2015-01-14 23:25 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-20 16:16:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Pfeifer 2010-05-29 21:46:26 UTC
Description of problem:
Once I lock the screen, there is no way to unlock it again.  When I hit
any key or move the mouse, the gdm(?) background image is shown for a
second and then the screen blanks again.  Never do I even see the dialog
where to enter my password or leave a message.

Version-Release number of selected component (if applicable):
gnome-screensaver-2.30.0-1.fc13.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Lock screen.
2. Hit a key or move mouse to obtain password dialog.
3. Screen briefly shows background instead.
  
Expected results:
Password dialog appears.

Additional info:
No desktop effects are active 

# lshw -class display
  *-display:0             
       description: VGA compatible controller
       product: Mobile 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:33 memory:f4400000-f47fffff memory:d0000000-dfffffff(prefetchable) ioport:1800(size=8)
  *-display:1 UNCLAIMED
       description: Display controller
       product: Mobile 4 Series Chipset Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 07
       width: 64 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:f4200000-f42fffff

Comment 1 Martin Poole 2010-06-08 17:34:59 UTC
Am seeing this on Lenovo T60p

gnome-screensaver-2.30.0-1.fc13.i686


# lshw -class display
  *-display:0             
       description: VGA compatible controller
       product: Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 03
       width: 32 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:16 memory:ee100000-ee17ffff ioport:1800(size=8) memory:d0000000-dfffffff(prefetchable) memory:ee200000-ee23ffff
  *-display:1 UNCLAIMED
       description: Display controller
       product: Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 03
       width: 32 bits
       clock: 33MHz
       capabilities: pm cap_list
       configuration: latency=0
       resources: memory:ee180000-ee1fffff

Comment 2 Martin Poole 2010-06-08 17:45:58 UTC
Looks like this is not a gnome-screensaver problem

It is caused by a problem in pam_pkcs11


Jun  8 18:39:30 t60 gnome-screensaver-dialog: PAM unable to dlopen(/lib/security/pam_pkcs11.so): /lib/security/pam_pkcs11.so: undefined symbol: get_sl
ot_login_required
Jun  8 18:39:30 t60 gnome-screensaver-dialog: PAM adding faulty module: /lib/security/pam_pkcs11.so


# rpm -qf /lib/security/pam_pkcs11.so
pam_pkcs11-0.6.2-2.fc13.i686


This is being tracked in BZ#597501

Workarounds are to downgrade the pam_pkcs11 package or to comment out the two pam_pkcs11 lines in /etc/pam.d/system-auth

Comment 3 Gerald Pfeifer 2010-06-11 18:04:34 UTC
No, this appears to be something different:

  # grep -r pam_pkcs11 /var/log

  # rpm -e pam_pkcs11
  # 

Yet, even after a reboot, the problem still appears.

Comment 4 Johan Vervloet 2010-06-15 11:25:06 UTC
Workaround when the problem occurs: ssh to the machine, and

  killall gnome-screensaver

Comment 5 Santtu Pajukanta 2010-06-18 07:27:06 UTC
On my box, this bug was fixed by some recent upgrade (xscreensaver-base 4.1.fc13.respin1 I guess).

I believe #603744 and #532901 are related.

Comment 6 Gerald Pfeifer 2010-06-20 16:16:42 UTC
Confirming as resolved with the latest updates.


Note You need to log in before you can comment on or make changes to this bug.