Bug 597644 - [abrt] crash in eclipse-platform-1:3.5.2-1.fc13: Process /usr/lib/eclipse/eclipse was killed by signal 6 (SIGABRT)
[abrt] crash in eclipse-platform-1:3.5.2-1.fc13: Process /usr/lib/eclipse/ecl...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
abrt_hash:435ae15d9bc2b430e3881654c6d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-29 19:11 EDT by Mads Kiilerich
Modified: 2010-08-24 18:29 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-24 18:29:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (21.50 KB, text/plain)
2010-05-29 19:11 EDT, Mads Kiilerich
no flags Details
new crash - new backtrace (140.45 KB, text/plain)
2010-06-04 11:43 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2010-05-29 19:11:35 EDT
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/eclipse/eclipse
component: eclipse
executable: /usr/lib/eclipse/eclipse
global_uuid: 435ae15d9bc2b430e3881654c6d698833de48ead
kernel: 2.6.33.4-95.fc13.i686.PAE
package: eclipse-platform-1:3.5.2-1.fc13
rating: 4
reason: Process /usr/lib/eclipse/eclipse was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)

How to reproduce
-----
Eclipse just crashed.
It seems like this backtrace doesn't say much:
abort() with "warning: can't find linker symbol for virtual table for `(null)' value"
some fatal error was detected "*** glibc detected *** %s: %s: 0x%s ***\n"
Comment 1 Mads Kiilerich 2010-05-29 19:11:38 EDT
Created attachment 417939 [details]
File: backtrace
Comment 2 Mads Kiilerich 2010-06-04 11:43:36 EDT
Created attachment 421273 [details]
new crash - new backtrace

I got something similar again. This time abrt rejected to report it (for strange reasons).

This was on another machine, but probably with the same CDT project.
Comment 3 Andrew Overholt 2010-08-23 15:29:49 EDT
Hi Mads.  Can you provide the CDT project for debugging purposes?
Comment 4 Mads Kiilerich 2010-08-23 18:58:35 EDT
Sorry, I don't remember which project it was. But probably nothing fancy; probably just some existing autotools-based project which I somehow tricked CDT to consider an autotool project.

I haven't seen it since.

I now consider it very likely that it is a duplicate of https://bugzilla.redhat.com/buglist.cgi?quicksearch=+invalid+fastbin+entry and has been fixed in glibc?
Comment 5 Andrew Overholt 2010-08-24 18:29:37 EDT
Thanks, Mads.  I'm not sure about that glibc issue but if you haven't seen it recently, I'll close this.

Note You need to log in before you can comment on or make changes to this bug.