Bug 597711 - Latest version 3.7.21-19 broke mounting enciphered home partition with pam-mount
Latest version 3.7.21-19 broke mounting enciphered home partition with pam-mount
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-30 04:51 EDT by Pierre Juhen
Modified: 2011-06-02 09:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-02 09:44:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Juhen 2010-05-30 04:51:16 EDT
Description of problem:
Pam-mount fails to mount enciphered home partition

Version-Release number of selected component (if applicable):
version 3.7.21-19

How reproducible:
  

Steps to Reproduce:
1.Upgrade from 3.7.21-19
2.Reboot
3.
  
Actual results:
Partition are note mounted with 12 selinux errors
Permissive mode is OK
Downgrade to 3.7.21-10 solves the issue

Expected results:


Additional info:
Comment 1 Daniel Walsh 2010-06-01 16:37:27 EDT
I do not know where you get these version numbers from.

I think the problem you are seeing is caused by a pam_mounts that does the cryptsetup within mount.crypt.
Comment 2 Daniel Walsh 2010-06-01 16:40:30 EDT
I think this is fixed in selinux-policy-3.7.19-22.fc13
Comment 3 Pierre Juhen 2010-06-24 16:05:27 EDT
I tried all updates until selinux-policy-3.7.19-28.fc13. Still not working.

I think this is the same issue as bug NĀ°599609.
Comment 4 Daniel Walsh 2010-06-25 15:38:09 EDT
Yes it is the same.
Comment 5 Bug Zapper 2011-06-02 08:48:23 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Pierre Juhen 2011-06-02 09:44:06 EDT
The problem was solved later.

Note You need to log in before you can comment on or make changes to this bug.