Bug 597791 - [abrt] crash in awn-extras-applets-0.4.0-11.fc13: awnlib.py:209:unregister:RuntimeError: Dialog 'secondary' not registered
Summary: [abrt] crash in awn-extras-applets-0.4.0-11.fc13: awnlib.py:209:unregister:Ru...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: awn-extras-applets (Show other bugs)
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: leigh scott
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f70a0499
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-30 14:21 UTC by Jhonny Oliveira
Modified: 2010-06-05 17:39 UTC (History)
5 users (show)

Fixed In Version: awn-extras-applets-0.4.0-12.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-04 18:51:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (809 bytes, text/plain)
2010-05-30 14:21 UTC, Jhonny Oliveira
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 581414 None None None Never

Description Jhonny Oliveira 2010-05-30 14:21:19 UTC
abrt 1.1.0 detected a crash.

architecture: x86_64
cmdline: python /usr/share/avant-window-navigator/applets/weather/weather.py --uid=1275169715 --window=33554479 --panel-id=1
component: awn-extras-applets
executable: /usr/share/avant-window-navigator/applets/weather/weather.py
kernel: 2.6.33.4-95.fc13.x86_64
package: awn-extras-applets-0.4.0-11.fc13
reason: awnlib.py:209:unregister:RuntimeError: Dialog 'secondary' not registered
release: Fedora release 13 (Goddard)

backtrace
-----
awnlib.py:209:unregister:RuntimeError: Dialog 'secondary' not registered

Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/awn/extras/threadqueue.py", line 79, in _callback
    callback(*args)
  File "/usr/share/avant-window-navigator/applets/weather/weather.py", line 519, in error_cb
    self.network_error_cb(e, tb)
  File "/usr/share/avant-window-navigator/applets/weather/weather.py", line 246, in network_error_cb
    self.applet.dialog.unregister("secondary")
  File "/usr/lib64/python2.6/site-packages/awn/extras/awnlib.py", line 209, in unregister
    raise RuntimeError("Dialog '%s' not registered" % dialog)
RuntimeError: Dialog 'secondary' not registered

Local variables in innermost frame:
self: <awn.extras.awnlib.Dialogs instance at 0x2710560>
dialog: 'secondary'

Comment 1 Jhonny Oliveira 2010-05-30 14:21:22 UTC
Created attachment 418035 [details]
File: backtrace

Comment 2 leigh scott 2010-05-30 14:54:55 UTC
Bug forwarded upstream https://bugs.launchpad.net/awn-extras/+bug/581414

Comment 3 Norfaisal Ismail 2010-06-02 15:16:56 UTC
Package: awn-extras-applets-0.4.0-11.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.this is happen when network connected to office corp line that prevent some udp/tcp transport
2office lan is using proxy and use some port filtering to prevent user to access connection via certain udp/tcp port
3.

Comment 4 Fedora Update System 2010-06-04 08:19:32 UTC
awn-extras-applets-0.4.0-12.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/awn-extras-applets-0.4.0-12.fc12

Comment 5 Fedora Update System 2010-06-04 08:19:32 UTC
awn-extras-applets-0.4.0-12.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/awn-extras-applets-0.4.0-12.fc13

Comment 6 Fedora Update System 2010-06-04 18:51:04 UTC
awn-extras-applets-0.4.0-12.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2010-06-04 18:58:29 UTC
awn-extras-applets-0.4.0-12.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Jhonny Oliveira 2010-06-05 16:53:06 UTC
This problem happens because I only start internet connection after the applet loads (lets say, one minute later - I'm using a 3G modem). After the latest update the crash no longer manifests it self, but the applet is still unable to display the proper state after a start my modem, it keeps on "Fetching conditions for..." for ever.
My suggestion to fix this problem, is to make the applet "network connectivity" aware, get this state from Network Manager or something like that...

Hope I can help.

Comment 9 leigh scott 2010-06-05 17:39:55 UTC
(In reply to comment #8)
> This problem happens because I only start internet connection after the applet
> loads (lets say, one minute later - I'm using a 3G modem). After the latest
> update the crash no longer manifests it self, but the applet is still unable to
> display the proper state after a start my modem, it keeps on "Fetching
> conditions for..." for ever.
> My suggestion to fix this problem, is to make the applet "network connectivity"
> aware, get this state from Network Manager or something like that...
> 
> Hope I can help.    


Hi,

Can you forward your comments upstream so they can fix it for everyone .

https://bugs.launchpad.net/awn-extras/+bug/581414

Thanks

Leigh


Note You need to log in before you can comment on or make changes to this bug.