Bug 597813 - Gnome keeps whining that my disk is almost full ... but it isn't
Summary: Gnome keeps whining that my disk is almost full ... but it isn't
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-30 16:08 UTC by Arjan van de Ven
Modified: 2010-10-27 10:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-27 10:41:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Arjan van de Ven 2010-05-30 16:08:38 UTC
Description of problem:

my 60Gb Linux partition has 2Gb of free space.... which is more than plenty
(it's not changing much) but Gnome keeps popping up the dialog that it's almost full.
2Gb free (and stable) is NOT almost full.

Comment 1 Deji Akingunola 2010-05-31 01:35:06 UTC
I would have say 2Gb of 60Gb (mere 3%) is almost full too ;). Baobab is no more a stand-alone app, it's been part of gnome-utils for years.

Comment 2 Arjan van de Ven 2010-05-31 03:34:36 UTC
I think your comment shows exactly what's wrong with the code..
it looks at %age only, not at the absolute amount of space, nor at growth rates...

2Gb is a lot of space, especially since the grow rate of the amount of data is near zero.


if I had 100 Tb of data in a volume, to store movies, and it's only 3% empty... but I'm not adding movies anymore... should it warn? I'd think not. 3Tb is a lot of free space ;-)

Comment 3 Bastien Nocera 2010-10-27 10:41:30 UTC
(In reply to comment #2)
> I think your comment shows exactly what's wrong with the code..
> it looks at %age only, not at the absolute amount of space, nor at growth
> rates...

It looks at the amount of space. And the minimum when we start warning is 2GB.

> 2Gb is a lot of space, especially since the grow rate of the amount of data is
> near zero.
> 
> 
> if I had 100 Tb of data in a volume, to store movies, and it's only 3% empty...
> but I'm not adding movies anymore... should it warn? I'd think not. 3Tb is a
> lot of free space ;-)

Right, and it wouldn't show up because it's about 2GB of data. See the /apps/gnome_settings_daemon/plugins/housekeeping/free_size_gb_no_notify GConf key.

Anyway, if you want to discuss a change in behaviour, file an upstream bug.


Note You need to log in before you can comment on or make changes to this bug.