Bug 59782 - konqueror crash
konqueror crash
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: kdebase (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-13 04:01 EST by Tim Waugh
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-13 04:02:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2002-02-13 04:01:36 EST
Description of Problem:
Just got this backtrace.  I had just pressed the right mouse button in a
konqueror browser window.

Version-Release number of selected component (if applicable):
kdebase-3.0.0-0.cvs20020211.1
kdelibs-3.0.0-0.cvs20020211.1
qt-3.0.2-0.cvs20020118.2

How Reproducible:
I can't seem to reproduce it on demand.

Actual Results:
(no debugging symbols found)...[New Thread 1024 (LWP 2705)]
0x40fddff9 in wait4 () from /lib/i686/libc.so.6
#0  0x40fddff9 in wait4 () from /lib/i686/libc.so.6
#1  0x4106c690 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x40e17483 in waitpid () from /lib/i686/libpthread.so.0
#3  0x40608895 in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#4  0x40e157fc in pthread_sighandler () from /lib/i686/libpthread.so.0
#5  <signal handler called>
#6  0x41652850 in DOM::DocumentImpl::prepareMouseEvent(int, int, DOM::NodeImpl::
MouseEvent*) () from /usr/lib/libkhtml.so.4
#7  0x4161bdcd in KHTMLView::contentsContextMenuEvent(QContextMenuEvent*) ()
   from /usr/lib/libkhtml.so.4
#8  0x409a8296 in QScrollView::viewportContextMenuEvent(QContextMenuEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#9  0x409a7864 in QScrollView::eventFilter(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#10 0x408b980f in QObject::activate_filters(QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#11 0x408b9740 in QObject::event(QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#12 0x408edadc in QWidget::event(QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#13 0x4086cce4 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#14 0x4086cb0a in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0x40598286 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdecore.so.4
#16 0x40816f09 in QETWidget::translateMouseEvent(_XEvent const*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0x40814061 in QApplication::x11ProcessEvent(_XEvent*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#18 0x40813bc6 in QApplication::processNextEvent(bool) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0x4086e2c0 in QApplication::enter_loop() ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0x408135bd in QApplication::exec() () from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0x412bfd07 in main () from /usr/lib/konqueror.so
#22 0x0804ce7a in strcpy ()
#23 0x0804dbc0 in strcpy ()
#24 0x0804e0f9 in strcpy ()
#25 0x0804ee70 in strcpy ()
#26 0x40f3d108 in __libc_start_main () from /lib/i686/libc.so.6
Comment 1 Bernhard Rosenkraenzer 2002-02-15 04:43:21 EST
Can't reproduce it, and I don't see anything obviously wrong in the code if 
prepareMouseEvent().

Note You need to log in before you can comment on or make changes to this bug.