Bug 597895 - AttributeError: 'NoneType' object has no attribute 'path'
Summary: AttributeError: 'NoneType' object has no attribute 'path'
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 13
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:7818ab3c26173f745...
Keywords:
: 603164 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-30 22:25 UTC by fredsilsbee
Modified: 2010-10-12 20:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-10 18:44:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (286.74 KB, text/plain)
2010-05-30 22:25 UTC, fredsilsbee
no flags Details
Attached traceback automatically from anaconda. (313.78 KB, text/plain)
2010-10-12 20:00 UTC, Jordi Genis
no flags Details

Description fredsilsbee 2010-05-30 22:25:30 UTC
The following was filed automatically by anaconda:
anaconda 13.42 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/booty/util.py", line 5, in getDiskPart
    path = storage.devicetree.getDeviceByName(dev).path[5:]
  File "/usr/lib/anaconda/booty/bootloaderInfo.py", line 355, in setDevice
    (dev, part) = getDiskPart(device, self.storage)
  File "/usr/lib/anaconda/iw/upgrade_bootloader_gui.py", line 65, in getNext
    self.bl.setDevice(devicePathToName(self.bootDev))
  File "/usr/lib/anaconda/gui.py", line 1309, in nextClicked
    rc = self.currentWindow.getNext ()
AttributeError: 'NoneType' object has no attribute 'path'

Comment 1 fredsilsbee 2010-05-30 22:25:35 UTC
Created attachment 418115 [details]
Attached traceback automatically from anaconda.

Comment 2 fredsilsbee 2010-05-30 23:06:13 UTC
will preupgrade be changed so I can update the version on my Fedora 12 and continue upgrade

I was upgrading Fedora 12 -> Fedora 13 or trying to.

I booted the iso DVD (3.1 gig) and answered all the questions

It asked if I was upgrading from a previous version and I selected Fedora 12 (the only entry)

Comment 3 fredsilsbee 2010-06-09 13:52:36 UTC
Comment on attachment 418115 [details]
Attached traceback automatically from anaconda.

I suppose using this path to upgrade 12->13 is blocked. 

I have the lates version of preupgrade

Comment 4 fredsilsbee 2010-06-09 13:59:21 UTC
http://docs.fedoraproject.org/en-US/Fedora/13/html/Installation_Guide/sn-upgrading-system-x86.html#sn-upgrade-examine-x86

does NOT work...it couldn't be simpler!

Will this get fixed or must I completely install from scratch F13?

Comment 5 Hans de Goede 2010-06-09 14:42:38 UTC
2 questions:

1) When asked which disks to use during installation have you checked all your disks ? Not checking all of them could cause this error

2) What does your disk layout (parititions, lvm, mounpoints, etc). Look like ?

Thanks,

Hans

Comment 6 fredsilsbee 2010-06-10 18:31:32 UTC
Thanks!
Simple
(1) SCSI #0 has MS XP Prof SP3
(2) SCSI #1 has Fedora 12

so far I've only been asked where to install and the obvious answer to that since this is an upgrade is SCSI #1

Fedora 12 uses the default disk layout selected month or two ago when I selected SCSI1 as the target drive for Fedora 12.

Obviously I do not want to mess up XP Prof on SCSI #0.

Preupgrade is supposed to be automatic...right?

I s there some othe information you need I can switch to Fedora and include it in the bugzilla additional comments

Comment 7 Hans de Goede 2010-06-10 18:44:04 UTC
The first disk selection screen is what we call the filter UI (we need to change the wording to make it more clear what that screen does). By not selecting a disk there you are telling anaconda to not touch the disk in *anyway*, but your bootloader is installed there, the traceback you've reported is caused by anaconda not seeing the disk the bootloader is installed to, as it is filtered out.

So the solution to get an upgrade to F-13 working is to select both disks in the first disk selection screen.

As said we are working on making this more intuitive, but that is being tracked in another bug.

Comment 8 Chris Lumens 2010-06-11 18:09:37 UTC
*** Bug 603164 has been marked as a duplicate of this bug. ***

Comment 9 Jordi Genis 2010-10-12 20:00:57 UTC
Created attachment 453023 [details]
Attached traceback automatically from anaconda.


Note You need to log in before you can comment on or make changes to this bug.