Bug 59797 - lvm ioctl error and lpfcdd module usage count not incrementing
lvm ioctl error and lpfcdd module usage count not incrementing
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-13 09:50 EST by Satish
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-13 09:50:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satish 2002-02-13 09:50:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT; Hewlett-Packard 
IE5.01 SP1)

Description of problem:
With an md device (mulitpath module) /dev/md0 with 2 paths,an lpfcdd driver,
configured under LVM, we create a vg and activate it, the following error is 
seen :
lvm_chr_ioctl: unknown command 4004fe0a

THe module usage count does not increment for the lpfcdd driver for
every vg activated
However, the volume grups are activated

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. create an md device with multipath module with 2 alternate paths to an end 
device with lpfcdd driver 4.12c loaded
2. create volume group and activate it
3. The behaviour mentioned above is seen
	

Actual Results:  lvm_chr_ioctl: unknown command 4004fe0a

THe module usage count does not increment for the lpfcdd driver for
every vg activated


Expected Results:  THe module usage count should have incremented for the 
lpfcdd driver for every vg activated and volume mounted


Additional info:
Comment 1 Arjan van de Ven 2002-02-13 10:00:08 EST
Interesting bug ;(
1) We don't ship with LVM because it doesn't work yet
2) We don't support binary only kernel modules, and as a result emulex hardware
is    unsupported. 

2) is rather important: _IF_ we had the (full) source, we would be in a position
to fix your bug, but since the driver is binary only there's no way we can help
you. 

Please report your bug to emulex instead.

Note You need to log in before you can comment on or make changes to this bug.