Bug 59799 - up2date dumps core while loading list of installed rpms
up2date dumps core while loading list of installed rpms
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-13 09:52 EST by none
Modified: 2015-01-07 18:54 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-11 15:46:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description none 2002-02-13 09:52:49 EST
Description of Problem:

up2date dumps core while loading list of installed packages

Version-Release number of selected component (if applicable):
Redhat 7.0
# rpm -qf /usr/bin/up2date
up2date-gnome-2.5.4-1
up2date --version shows Update Agent 2.5.4

How Reproducible:

every time

Steps to Reproduce:
1. run up2date
2. 
3. 

Actual Results:

dumps core

Expected Results:

should work

Additional Information:

# gdb /usr/bin/python core
.... 
(gdb) where
#0  0x2ab98f27 in strlen (str=0x0) at ../sysdeps/i386/strlen.c:28
#1  0x2ac70a37 in i18nTag () from /usr/lib/librpm-4.0.3.so
#2  0x2ac70c94 in summaryTag () from /usr/lib/librpm-4.0.3.so
#3  0x2ac7ba99 in getExtension () from /usr/lib/librpm-4.0.3.so
#4  0x2ac7bb3d in formatValue () from /usr/lib/librpm-4.0.3.so
#5  0x2ac7c10f in singleSprintf () from /usr/lib/librpm-4.0.3.so
#6  0x2ac7c76f in headerSprintf () from /usr/lib/librpm-4.0.3.so
#7  0x2ac7fe66 in rpmHeaderGetEntry () from /usr/lib/librpm-4.0.3.so
#8  0x2ac7ff79 in rpmPackageGetEntry () from /usr/lib/librpm-4.0.3.so
#9  0x2aac6db5 in hdrSubscript () at eval.c:41
#10 0x8066194 in PyObject_GetItem () at eval.c:41
#11 0x8052046 in PyEval_EvalCode () at eval.c:41
#12 0x8053568 in PyEval_EvalCode () at eval.c:41
#13 0x8054ad1 in PyEval_CallObjectWithKeywords () at eval.c:41
#14 0x805469f in PyEval_CallObjectWithKeywords () at eval.c:41
#15 0x80697aa in PyInstance_New () at eval.c:41
#16 0x8066223 in PyObject_SetItem () at eval.c:41
#17 0x8052483 in PyEval_EvalCode () at eval.c:41
#18 0x8053568 in PyEval_EvalCode () at eval.c:41
#19 0x8053568 in PyEval_EvalCode () at eval.c:41
#20 0x8053568 in PyEval_EvalCode () at eval.c:41
#21 0x8053568 in PyEval_EvalCode () at eval.c:41
#22 0x8053568 in PyEval_EvalCode () at eval.c:41
#23 0x8053568 in PyEval_EvalCode () at eval.c:41
---Type <return> to continue, or q <return> to quit---q
Quit
Comment 1 Need Real Name 2002-03-11 15:43:26 EST
Completely patched 7.2 suddenly bombs after up2date under gnome.
up2date in RL3 also bombs out
Python seg faults after header downloaded
Tried rolling back python-xmlrpc and up2date and rhn rpms - no luck
System stuffed
RHCEX needs fix asap
If I get this on a 300 course I will look complete potato head ! ;-)
Comment 2 Need Real Name 2002-03-11 15:44:08 EST
Completely patched 7.2 suddenly bombs after up2date under gnome.
up2date in RL3 also bombs out
Python seg faults after header downloaded
Tried rolling back python-xmlrpc and up2date and rhn rpms - no luck
System stuffed
RHCEX needs fix asap
If I get this on a 300 course I will look complete potato head ! ;-)
Comment 3 Adrian Likins 2002-03-11 15:46:22 EST
try:
    rm -rf /var/spool/up2date/*.hdr

Looks like a corrupted header file in your cache dir. This can
cause rpm/up2date to segfault.

The next version of the client is going to be more robust in
this regard.

Note You need to log in before you can comment on or make changes to this bug.