Bug 598055 - F13 x86_64 install from an external USB drive impossible
F13 x86_64 install from an external USB drive impossible
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
: 598683 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-31 06:37 EDT by Joachim Backes
Modified: 2010-11-19 18:18 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-19 18:18:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
camera picture of tty4 (566.57 KB, image/jpeg)
2010-07-27 11:11 EDT, Joachim Backes
no flags Details
tty1 (215.49 KB, image/jpeg)
2010-07-27 11:13 EDT, Joachim Backes
no flags Details

  None (edit)
Description Joachim Backes 2010-05-31 06:37:27 EDT
Description of problem:
Booting the F13 x86_64 install DVD from my *external USB DVD* drive. During this installprocedure, anaconda does not find an installmedia ("Press F2 to configure devices").

If I press F2, then anaconda presents 4 found additional devices:
sr0 (an existing ata DVD drive)
sr1 (an existing ata DVD drive)
fdo
sr2 (the external DVD drive I booted from)

Then I activate sr2 and press OK, but nothing happens. After going back, the above decribed prompt ("Press F2 to configure devices") is shown again, and so on.

Version-Release number of selected component (if applicable):
Anaconda on the x86_64 install disk

How reproducible:
I tried a lot of times with the same result

Steps to Reproduce:
1.See description!
2.
3.
  
Actual results:
Never ending prompting for the install device

Expected results:
install continues

Additional info:

1. I did not check the i386 DVD, but I guess, we will have the same behaviour.
2. I had exactly the same problems in earlier times when installing F12
3. Installation from both IDE DVD drives is done flawless
Comment 1 Nickolay Bunev 2010-05-31 06:44:18 EDT
seems to be an old problem:
https://bugzilla.redhat.com/show_bug.cgi?id=539720
Comment 2 Joachim Backes 2010-05-31 07:05:55 EDT
(In reply to comment #1)
> seems to be an old problem:
> https://bugzilla.redhat.com/show_bug.cgi?id=539720    

I think: even old problems should be solved too :-)
Comment 3 Chris Lumens 2010-06-01 11:16:49 EDT
Please attach /tmp/anaconda.log and /tmp/syslog to this bug report.  Thanks.
Comment 4 Joachim Backes 2010-06-01 12:38:06 EDT
(In reply to comment #3)
> Please attach /tmp/anaconda.log and /tmp/syslog to this bug report.  Thanks.    

1. This is *not* possible because in this very early situation, there is no shell
   in any of the virtual consoles (only output to these consoles, 
   no input possible). 

2. I could solve the problem by editing the grub bootline of the DVD boot window:
   changing stage2=hd.label="Fedora" into stage2=cd.label="Fedora". Then the
   installation proceeds with the external USB dvd device. But how should a
   newbie know this trick?

   Is this a documented solution?

   It was only an attempt I tried coincidentally (obviously successful).

Kind regards

Joachim Backes
Comment 5 Chris Lumens 2010-06-01 20:13:03 EDT
*** Bug 598683 has been marked as a duplicate of this bug. ***
Comment 6 Chris Lumens 2010-07-16 15:10:22 EDT
You can always take a picture of tty3 and tty4 and attach those to this report.
Comment 7 Joachim Backes 2010-07-27 10:25:06 EDT
If adding "askmethod" to the kernel boot line (when booting from USB cd), then selecting "local cd drive" after having answered the language and keyboard question, the installation process proceeds as expected into the Xwindow based installation process.
Comment 8 Joachim Backes 2010-07-27 11:11:06 EDT
Created attachment 434724 [details]
camera picture of tty4

Picture taken from tty4. Hope you can read it. The picture I made from tty3 in this situation is not readable.
Comment 9 Joachim Backes 2010-07-27 11:13:06 EDT
Created attachment 434725 [details]
tty1

Picture taken from tty1
Comment 10 Anthony Thyssen 2010-08-12 20:40:15 EDT
This same problem appears to be for a installation from a ISO image on a USB stick.

Create bootable USB installation stick
   livecd-iso-to-disk  Fedora-13-i386-netinst.iso /dev/sdX1

(I want to install from a local network source!)

Boot from it.
Go though installation procedure.
get message "Transferring image to device"
for a moment before you get error...

   The installer has tried to mount image #1, but cannot find it on the hard drive.

   Please copy this image to the drive and click Retry.   Click Exit to abort the installation.

Pretty useless when you can't do what it suggests!
Comment 11 Brian Lane 2010-09-27 18:47:05 EDT
>    The installer has tried to mount image #1, but cannot find it on the hard
> drive.
> 
>    Please copy this image to the drive and click Retry.   Click Exit to abort
> the installation.
> 
> Pretty useless when you can't do what it suggests!

You can fix this by changing the kernel command line from repo=hd... to stage2=hd...

This has been fixed in the upstream version of livecd-iso-to-disk

Note You need to log in before you can comment on or make changes to this bug.