Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 598062 - [abrt] crash in pychess-0.10-0.4.20100504hg.fc13: preferencesDialog.py:309:<lambda>:AttributeError: 'NoneType' object has no attribute 'startswith'
[abrt] crash in pychess-0.10-0.4.20100504hg.fc13: preferencesDialog.py:309:<l...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pychess (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Thomas Spura
Fedora Extras Quality Assurance
abrt_hash:ac63b235
:
: 624233 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-31 06:50 EDT by GhostMan.227
Modified: 2010-08-24 21:21 EDT (History)
13 users (show)

See Also:
Fixed In Version: pychess-0.10-0.7.20100815hg.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-24 17:06:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (421 bytes, text/plain)
2010-05-31 06:51 EDT, GhostMan.227
no flags Details

  None (edit)
Description GhostMan.227 2010-05-31 06:50:57 EDT
abrt 1.1.0 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/pychess
component: pychess
executable: /usr/bin/pychess
kernel: 2.6.33.4-95.fc13.x86_64
package: pychess-0.10-0.4.20100504hg.fc13
reason: preferencesDialog.py:309:<lambda>:AttributeError: 'NoneType' object has no attribute 'startswith'
release: Fedora release 13 (Goddard)

backtrace
-----
preferencesDialog.py:309:<lambda>:AttributeError: 'NoneType' object has no attribute 'startswith'

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pychess/widgets/preferencesDialog.py", line 309, in <lambda>
    lambda data: data[3].startswith("audio/"))
AttributeError: 'NoneType' object has no attribute 'startswith'

Local variables in innermost frame:
data: (None, None, 'win2.ogg', None)
Comment 1 GhostMan.227 2010-05-31 06:51:03 EDT
Created attachment 418256 [details]
File: backtrace
Comment 2 Thomas Spura 2010-05-31 07:50:12 EDT
Thanks for the bug report.

I forwared this bug to pychess upstream:
http://code.google.com/p/pychess/issues/detail?id=559

It's reproducable with:
1. open pychess on the console
2. click on Settings->Preferences
3. When the window appears, see the backtrace on the console.


Please make some similar 'how to reproduce' notes next time.

Thanks.
Comment 3 John William 2010-06-10 03:41:55 EDT
Package: pychess-0.10-0.5.20100511hg.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


Comment
-----
Crash during gameplay.
Comment 4 David Webb 2010-06-30 18:26:52 EDT
Package: pychess-0.10-0.5.20100511hg.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Open the Preferences Dialog.

2.
3.
Comment 5 John William 2010-07-07 04:18:50 EDT
Package: pychess-0.10-0.5.20100511hg.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Open preferences window.
2.
3.


Comment
-----
Crash during gameplay.
Comment 6 John William 2010-07-08 12:24:36 EDT
Package: pychess-0.10-0.5.20100511hg.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Open preferences window.
2.
3.


Comment
-----
Crash during gameplay.
Comment 7 Ameya Gore 2010-07-21 16:34:38 EDT
Package: pychess-0.10-0.5.20100511hg.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. open pychess.
2. Start Game Human vs PyChess 0.10beta
3. Rotate boards randomly.
4.  Clicke on Settings->Preferences
5. Its doesn't break, but abrt shows this error.
Comment 8 Chad Rhyner 2010-07-30 00:25:13 EDT
Package: pychess-0.10-0.5.20100511hg.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.  Started playing a new game.
2.  Selected the PyChess Beta 0.10 player.
3.  Waited for game to start.
4.  Was looking through Game, Actions, View, & Settings.
5.  When I got to Settings, I clicked on Preferences.
6.  After the Preferences Panel opened up, PyChess crashed.
7.  Despite crashing, I was still able to close the Preferences window, and start playing my game of chess.  The crash is not noticeable.


Comment
-----
Opening up the Preferences window causes PyChess to crash.
Comment 9 Thomas Spura 2010-08-15 07:59:41 EDT
*** Bug 624233 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2010-08-15 09:10:36 EDT
pychess-0.10-0.7.20100815hg.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/pychess-0.10-0.7.20100815hg.fc13
Comment 11 Fedora Update System 2010-08-15 09:10:41 EDT
pychess-0.10-0.7.20100815hg.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/pychess-0.10-0.7.20100815hg.fc14
Comment 12 Fedora Update System 2010-08-16 12:03:05 EDT
pychess-0.10-0.7.20100815hg.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pychess'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/pychess-0.10-0.7.20100815hg.fc14
Comment 13 Fedora Update System 2010-08-24 17:06:35 EDT
pychess-0.10-0.7.20100815hg.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2010-08-24 21:21:37 EDT
pychess-0.10-0.7.20100815hg.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.