Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 598107 - /etc/kshrc missing pathmunge
/etc/kshrc missing pathmunge
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ksh (Show other bugs)
5.5
All Linux
low Severity low
: rc
: ---
Assigned To: Michal Hlavinka
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-31 09:00 EDT by Michal Hlavinka
Modified: 2011-10-03 10:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 597647
Environment:
Last Closed: 2011-10-03 10:47:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Hlavinka 2010-05-31 09:00:07 EDT
+++ This bug was initially created as a clone of Bug #597647 +++

Created an attachment (id=417942)
Corrected /etc/kshrc file

Description of problem:
When using ksh with ccache installed, the /etc/profile.d/ccache.sh script reports that pathmunge is not found.

Version-Release number of selected component (if applicable):
ksh-20100309-3.fc13.x86_64

How reproducible:


Steps to Reproduce:
1. Open terminal program (xterm)
2. at prompt type: /bin/ksh
  
Actual results:
/home/user/.kshrc[15]: .[29]: .[4]: pathmunge: not found [No such file or directory]


Expected results:
Silence

Additional info:
Can be fixed by modifying /etc/kshrc to more closely match /etc/zshrc.  In this case, define the pathmunge() function in /etc/kshrc and unset it at the end of the script.  See attachment for corrected /etc/kshrc

--- Additional comment from ovasik@redhat.com on 2010-05-31 06:49:10 EDT ---

Or better one - without grep ... https://bugzilla.redhat.com/show_bug.cgi?id=544652#c7 ... it is much faster.
Comment 2 RHEL Product and Program Management 2010-08-09 14:20:07 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2011-01-11 15:21:29 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2011-01-11 17:44:37 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 5 RHEL Product and Program Management 2011-05-31 09:20:22 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 Michal Hlavinka 2011-10-03 10:47:41 EDT
I've missed that rhel 5.8 ksh does not ship kshrc. Adding kshrc to rhel 5.8 so we can fix it does not make much sense, also it could change behaviour of some scripts and we don't want that. Closing WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.