Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 598171 - Network Manager drops PAN connections after succesfully establishing them with errors btusb_intr_complete and btusb_bulk_complete
Network Manager drops PAN connections after succesfully establishing them wit...
Status: CLOSED DUPLICATE of bug 586961
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-31 12:28 EDT by jesus
Modified: 2010-08-17 12:34 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-17 12:34:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jesus 2010-05-31 12:28:36 EDT
Description of problem:
Network Manager drops PAN connections 

Version-Release number of selected component (if applicable):
[root@localhost ~]# rpm -aq | grep Network
NetworkManager-pptp-0.7.997-3.git20100120.fc12.i686
NetworkManager-openvpn-0.7.996-4.git20090923.fc12.i686
NetworkManager-0.8.0-6.git20100408.fc12.i686
NetworkManager-gnome-0.8.0-6.git20100408.fc12.i686
NetworkManager-vpnc-0.7.996-4.git20090921.fc12.i686
NetworkManager-glib-0.8.0-6.git20100408.fc12.i686
[root@localhost ~]# rpm -aq | grep blue
bluez-4.58-1.fc12.i686
bluez-compat-4.58-1.fc12.i686
bluez-cups-4.58-1.fc12.i686
pulseaudio-module-bluetooth-0.9.21-5.fc12.i686
gnome-bluetooth-libs-2.28.6-2.fc12.i686
bluecurve-cursor-theme-8.0.2-5.fc12.noarch
bluez-libs-4.58-1.fc12.i686
gnome-bluetooth-2.28.6-2.fc12.i686


How reproducible:
Always

Steps to Reproduce:
1.Pair with your iPhone
2.Connect to the PAN Network via Network Manager
3.Will work for 30 seconds and then drop with messages in /var/log/messages

May 31 18:07:54 localhost kernel: btusb_intr_complete: hci0 urb f3b44a80 failed to resubmit (1)
May 31 18:07:54 localhost kernel: btusb_bulk_complete: hci0 urb f3b44d00 failed to resubmit (1)
May 31 18:07:54 localhost kernel: btusb_bulk_complete: hci0 urb f3b44880 failed to resubmit (1)

  
Actual results:

Works for a few seconds

Expected results:

Stays connected
Additional info:

Non Network Manager related components work as exprected:
running the following gets the connection running flawlessly:
pand --conncect BTADDRESS -n
dhclient bnep0
Comment 1 Dan Williams 2010-06-01 03:10:58 EDT
This is a kernel driver and/or Bluez issue and possibly related to crappy hardware (which is still a kernel driver issue), not an NM issue.
Comment 2 jesus 2010-06-01 05:32:06 EDT
(In reply to comment #1)
> This is a kernel driver and/or Bluez issue and possibly related to crappy
> hardware (which is still a kernel driver issue), not an NM issue.    

If you read the Additional info section, you will see that I already nailed it on NetworkManager.
Comment 3 Peter Svensson 2010-07-24 06:26:02 EDT
I have the same issue on Fedora 13. Starting the network with "pand" works. If I start it from NetworkManager the network goes down after a few seconds with the same messages as in the inital report.
Comment 4 Chuck Ebbert 2010-07-24 10:59:31 EDT
How is this a kernel bug when pand works and NetworkManager does not? If the hardware is "crappy" it should not work in either case.
Comment 5 Dan Williams 2010-08-17 12:34:04 EDT
This actually was a bug in NM, and was fixed in early May.

*** This bug has been marked as a duplicate of bug 586961 ***

Note You need to log in before you can comment on or make changes to this bug.