Bug 59818 - netstat -ic only shows data for one iteration
netstat -ic only shows data for one iteration
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: net-tools (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Ben Levenson
:
Depends On:
Blocks: 73750
  Show dependency treegraph
 
Reported: 2002-02-13 12:07 EST by Korey Chapman
Modified: 2015-03-04 20:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-11 09:25:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Korey Chapman 2002-02-13 12:07:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120

Description of problem:
The output of 'netstat -ic' is wrong.
It will show the field headings and interface data for the first itteration, and
then subsequent itterations only show the field headings and no data.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run 'netstat -ic'
2.
3.
	

Actual Results:  Here are the first three itterations from 'netstat -ic',
net-tools-1.60-3 on a 7.2 box (2.4.9-21 kernel):
Iface   MTU Met   RX-OK RX-ERR RX-DRP RX-OVR   TX-OK TX-ERR TX-DRP TX-OVR Flg
eth0   1500   0 1364387     18      0      0 4061495     14      0     13 BNRU
lo    16436   0    3592      0      0      0    3592      0      0      0 LRU
Iface   MTU Met   RX-OK RX-ERR RX-DRP RX-OVR   TX-OK TX-ERR TX-DRP TX-OVR Flg
Iface   MTU Met   RX-OK RX-ERR RX-DRP RX-OVR   TX-OK TX-ERR TX-DRP TX-OVR Flg

Expected Results:  Here are the first three itterations from 'netstat -ic',
net-tools-1.57-6 on a 7.1 box (2.4.9-21 kernel):
Iface   MTU Met    RX-OK RX-ERR RX-DRP RX-OVR    TX-OK TX-ERR TX-DRP TX-OVR Flg
eth0   1500   0 19417406      3      0      0 39446714      2      0      0 BRU
lo    16436   0      764      0      0      0      764      0      0      0 LRU
Iface   MTU Met    RX-OK RX-ERR RX-DRP RX-OVR    TX-OK TX-ERR TX-DRP TX-OVR Flg
eth0   1500   0 19417442      3      0      0 39446734      2      0      0 BRU
lo    16436   0      764      0      0      0      764      0      0      0 LRU
Iface   MTU Met    RX-OK RX-ERR RX-DRP RX-OVR    TX-OK TX-ERR TX-DRP TX-OVR Flg
eth0   1500   0 19417475      3      0      0 39446754      2      0      0 BRU
lo    16436   0      764      0      0      0      764      0      0      0 LRU

Additional info:

This was working in 7.1, but is not working in 7.2.  The output seems to be
incorrect every time, on every 7.2 box I have tried.
Comment 1 Phil Knirsch 2002-02-24 12:07:26 EST
Thats really strange. I'll take a look into it before the next versions goes out.

Read ya, Phil
Comment 2 Nigel Metheringham 2002-04-23 08:19:28 EDT
Looks like its in the current betas from the package version number (not tested
this through).

Debian has same bug - its from the upstream.  Fix is apparently
in pipeline, but not appeared as yet.

  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=109164&repeatmerged=yes
Comment 3 Phil Knirsch 2002-04-23 08:29:06 EDT
Cool, thanks for the info.

Waiting for upstream to fix it then. :-)

Read ya, Phil
Comment 4 Scott Edlund 2002-09-04 14:36:53 EDT
netstat -ic first run should show cumalitive data, subsequent runs should show
delta's.  Please see patch added to bug id#64862 that provides this desired (and
UNIX like) behaviour.
Comment 5 Phil Knirsch 2003-02-11 09:25:07 EST
Included patch and it works nicely again. Thanks for the patch. :-)

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.