Bug 59823 - attached message body is not displayed if header is stripped
attached message body is not displayed if header is stripped
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: pine (Show other bugs)
7.2
i386 Linux
low Severity low
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-13 12:49 EST by Ben Levenson
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-15 02:30:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Levenson 2002-02-13 12:49:37 EST
Description of Problem:
Pine doesn't display attached/forwarded messages ('message/rfc822') if the
(forwarded) message header is stripped.
-----------------------------------------------------------------
Date: Prickle-Prickle, the 44th day of Chaos in the YOLD 3168
From: foo@bar.com
Reply-To: bar@foo.com
To: com@bar.foo
Subject: blah
Parts/Attachments:
   1   Shown    12 lines  Text
   2   Shown    91 bytes  Message
   2.1 Shown     0 lines  Text
----------------------------------------

message text
blah blah blah 

- xxx

--
--*--*--*--*--*--*--*--*--*--*--*--*--*--*--*--*--*--*--*--*--*--*--*--*--*
signature information...

      a quote by Albert Einstein


    [ Part 2: "Included Message" ]



    [ Note: This message contains email list management information ]
-----------------------------------------------------------------

Version-Release number of selected component (if applicable):
pine-4.44-1.72.0


How Reproducible:
100%

Actual Results:
the attached/forwarded message body is not displayed
Part 2 should have included the message body. Instead it is blank.

Additional Information:
everything is displayed as expected when viewed in other mail readers (mutt).
Comment 1 Mike A. Harris 2002-02-13 13:02:40 EST
While viewing the message, I pressed "H" to enable full headers, and the
message displays fine then.  It appears, PINE's hiding more than headers
here.  I wonder if it is intentional or a bug.  I suspect a bug though.
I'll have a look in the code.

    [ Part 2: "Included Message" ]
 
D. Lawrence - 346E
B. Levinson - 346F
A. Brown - 346G
B. Brock - 346H
B. Organ - 345E
Comment 2 Mike A. Harris 2002-08-08 06:45:04 EDT
Defering for future release.
Comment 3 Mike A. Harris 2003-03-15 02:30:07 EST
If this problem is still present in current pine 4.44 (I haven't checked),
it's not likely we're going to fix it.  It may or may not be fixed in
pine 4.5x perhaps, but we're not shipping that currently, and pine is
deprecated.

Since nobody else has reported it, I suspect it's more of a slight
inconvenience than something we really need to worry about.  If it's
present in 4.5x, we should report it upstream.

Closing WONTFIX with move upstream stipulation.

Note You need to log in before you can comment on or make changes to this bug.