Bug 59825 - gfloppy produces corrupt ext2 filesystem
gfloppy produces corrupt ext2 filesystem
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gnome-utils (Show other bugs)
3.0
i686 Linux
low Severity low
: ---
: ---
Assigned To: Jonathan Blandford
Aaron Brown
: MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-13 13:13 EST by Need Real Name
Modified: 2013-04-02 00:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-09 11:50:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from e2fsck following execution of gfloppy. (2.98 KB, text/plain)
2002-02-13 13:14 EST, Need Real Name
no flags Details
Output from 'e2fsck -f -n /dev/fd0' after formatting floppy with gfloppy. (1.23 KB, text/plain)
2003-10-31 17:09 EST, Chris Kloiber
no flags Details

  None (edit)
Description Need Real Name 2002-02-13 13:13:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
gfloppy from the menu->programs->utils->gfloppy and electing to use the ext2
file system format produces a floppy which cannot be removed and mounted later.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.insert floppy into drive
2. run menu->programs->utils->gfloppy from GNOME desktop
3. select ext2 file high density 3.5" discs (1.44M).
4. press  format.
5. answer yes to format and no to format more disks
6. check disk format using /sbin/e2fsck -f /dev/hd0
	

Actual Results:  lots of errors reported by e2fsck see attached created by 
/sbin/e2fsck -f -n /dev/hd0


Expected Results:  e2fsck verifies format OK.
disk can be removed and re-inserted with Nautilus finding the correct file
system on the floppy.

Additional info:
Comment 1 Need Real Name 2002-02-13 13:14:47 EST
Created attachment 45564 [details]
output from e2fsck following execution of gfloppy.
Comment 2 Havoc Pennington 2002-02-24 11:50:48 EST
Have you tried it with more than one floppy disk? At least 1 in 10 floppy disks
are just broken...
Comment 3 Need Real Name 2002-02-26 07:33:26 EST
I have tried this on 2 separate installations of RH7.2 (a low cost notebook and 
a home built desktop). I have tried 3 diferent floppies (2 on the desktop and 1 
on the notebook) all with the same result.
The floppies seem to pass the low level format and the final check for bad 
blocks (as reported by gfloppy) following the creation of the ext2 file system.
I am puzzled that this only seems to be a problem on these disks when using 
gfloppy and that mke2fs does not show this problem.
Comment 4 Chris Kloiber 2003-10-31 17:09:48 EST
Created attachment 95641 [details]
Output from 'e2fsck -f -n /dev/fd0' after formatting floppy with gfloppy.
Comment 5 Daniel Reed 2004-02-09 11:50:02 EST
Filed upstream at: http://bugzilla.gnome.org/show_bug.cgi?id=133904

Note You need to log in before you can comment on or make changes to this bug.