Bug 598278 - [abrt] crash in audacity-1.3.11-0.1.beta.fc13: *** glibc detected *** audacity: invalid fastbin entry (free): 0x08fef648 *** (SIGABRT)
[abrt] crash in audacity-1.3.11-0.1.beta.fc13: *** glibc detected *** audacit...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: audacity (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
abrt_hash:ea9a695540e0bcb3e7d5430b1b7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-31 21:00 EDT by mark.mrwizard
Modified: 2010-07-15 09:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-15 09:31:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (67.97 KB, text/plain)
2010-05-31 21:01 EDT, mark.mrwizard
no flags Details

  None (edit)
Description mark.mrwizard 2010-05-31 21:00:59 EDT
abrt 1.1.0 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: audacity
comment: Was recording a podcast with standard audio input from a headset mic.  About 7 minutes in the program crashed.  Dunno if this matters but I had two headsets (both mic and headphones) plugged into slots with a 2 way splitter.  I'm totally unsure why it happened.
component: audacity
crash_function: raise
executable: /usr/bin/audacity
global_uuid: ea9a695540e0bcb3e7d5430b1b7f4ef544fe5279
kernel: 2.6.33.4-95.fc13.i686
package: audacity-1.3.11-0.1.beta.fc13
rating: 4
reason: Process /usr/bin/audacity was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. Havn't reproduced
2.
3.
Comment 1 mark.mrwizard 2010-05-31 21:01:02 EDT
Created attachment 418427 [details]
File: backtrace
Comment 2 Michael Schwendt 2010-06-06 01:59:02 EDT
The memory management in glibc aborted the program, because it ran into an unexpected/fatal error condition. Call trace is from within wxWidgets -> Pango. As whether it's due to something bad passed in from Audacity, cannot tell with only a brief look at the backtrace.
Comment 3 David Timms 2010-07-05 18:00:55 EDT
(In reply to comment #0)

> comment: Was recording a podcast with standard audio input from a headset mic. 
> About 7 minutes in the program crashed.  Dunno if this matters but I had two
> headsets (both mic and headphones) plugged into slots with a 2 way splitter. 
> I'm totally unsure why it happened.
What do you mean by slot ?
Is this 2 usb audio devices ?
or just analog audio into a 'mic in' socket ?

Did the issue recur ? 
Have you been using audacity ?

We have updated audacity to 1.3.12-beta which will be available shortly in
Fedora 13 updates testing repo:
yum --enablerepo=updates-testing update audacity

It would be good to hear how you go testing against your original test case,
and provide any positive or negative feedback in the koji update comments at:
https://admin.fedoraproject.org/updates/audacity-1.3.12-0.4.beta.fc13
Comment 4 mark.mrwizard 2010-07-05 18:59:52 EDT
By slot I mean standard audio input slot, so yes 'mic in'.  The issue has not re-occurred.  I've been using audacity for a long time, for this and other things and continue to use audacity for the same purpose from here on, that being recording podcasts.  If it happens again I'll bug it again and try to be more concrete.
Comment 5 David Timms 2010-07-09 10:22:20 EDT
(In reply to comment #4)
Thanks. Did your /tmp (or wherever you have audacity's temp recording set) or your save location fill up while you were recording ?
Comment 6 mark.mrwizard 2010-07-09 12:35:01 EDT
I can't say for sure, but I don't think so, because after I restarted the program I continued recording for another 10 minutes (the file was correctly restored up to the moment it crashed).

Note You need to log in before you can comment on or make changes to this bug.