Bug 59831 - GUI installer won't start on Dell Inspiron 8000 with GeForce2Go
GUI installer won't start on Dell Inspiron 8000 with GeForce2Go
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-13 14:06 EST by Alexandre Oliva
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-21 10:58:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2002-02-13 14:06:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204

Description of problem:
XFree86 does not support GeForce2 Go directly yet, but the VESA and framebuffer
drivers used to work just fine.  With the beta1 installer, they no longer do. 
The default boot fails to start X with the following message in /tmp/X.log:
(EE) VGA(0): Virtual height (0) is too small for the hardware (min 0)

I wonder if that's just because there's no video mode that supports 640x480x4,
as in the configuration file generated by Anaconda, no matter what video mode I
specify in the boot.  I tried the default boot mode, lowres and vga=773.

The default and vga=773 simply fell back to the text installer after failing to
start X.  When booting with vga=773, even after tweaking /tmp/XF86Config.test
and starting X with that, it didn't work well; the screen was garbled.

With lowres, anaconda started the graphical installer, but the actual resolution
on the screen appeared to be much smaller (say 320x200x4) than anaconda
expected, and only a small part of the familiar installation screen took up the
entire screen.  At start up, I saw only the right half of the ShadowMan logo,
and the letters `red' in the right half of the screen.  In the first interaction
screen, I'd see little left of the scroll bar `anual', `w.', `ML', `set.', etc.
 The upper half of the shadowman logo was cut, and I only say `re' and `Li' and
part of the `n' besides it.
Worse yet: the next buttons were not in the screen, and X wouldn't scroll as I
tried to move the mouse down as it does with a virtual display larger than the
screen, so I was stuck.  Nothing interesting in X.log :-(

In all cases, XF86Config.test was using the `vga' driver, and the DefaultDepth
was set to 4, with a single "Display" entry for Depth 4 with a single Mode,
"640x480".

I've heard bad things about the fb driver in XFree86 4, and only good things
about the VESA driver; perhaps we could at least offer VESA as an option, if not
the default?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start the installer from CD-ROM on an Dell Inspiron 8000 with a GeForce2 Go
video card.
2.Type just enter, or linux vga=773, or lowres in the boot prompt

	

Actual Results:  See above.

Expected Results:  I'd hope at least one of the above to work.  No graphical
installer for my laptop.

Additional info:

I've heard bad things about the fb driver in XFree86 4, and only good things
about the VESA driver; perhaps we could at least offer VESA as an option, if not
the default?
Comment 1 Michael Fulbright 2002-02-13 14:15:42 EST
There was an issue in beta 1 which caused the framebuffer X server to never be
tried.  We are currently using the XFree86 3.x framebuffer, but are going to
have people look at the issue in the kernel so hopefully we can move to XFree86 4.x.
Comment 2 Alexandre Oliva 2002-03-10 06:56:00 EST
Fixed in beta2.

Note You need to log in before you can comment on or make changes to this bug.