Bug 598310 - Hang compiling upstream wine directx.c (variable tracking)
Hang compiling upstream wine directx.c (variable tracking)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-31 23:55 EDT by Matt McCutchen
Modified: 2010-07-18 21:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: gcc-4.4.4-10.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-18 21:36:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed code demonstrating the problem (xz compressed) (162.31 KB, application/x-xz)
2010-05-31 23:55 EDT, Matt McCutchen
no flags Details
Backtrace of cc1 (2.81 KB, text/plain)
2010-05-31 23:59 EDT, Matt McCutchen
no flags Details

  None (edit)
Description Matt McCutchen 2010-05-31 23:55:26 EDT
Created attachment 418453 [details]
Preprocessed code demonstrating the problem (xz compressed)

Description of problem:
When I try to compile the latest upstream wine (bbd93e535a3df9141cd9b028d2dfedae0c36eb5d), gcc appears to hang on dlls/wined3d/directx.c .

Version-Release number of selected component (if applicable):
gcc-4.4.4-2.fc13.x86_64

How reproducible:
Always

Steps to Reproduce:
Compile the attached preprocessed file as follows:
gcc -m32 -c -fPIC -fno-strict-aliasing -g -O2 -o directx-test.o directx.i

Actual results:
gcc ran for 3 minutes at 100% CPU, then I killed it.

Expected results:
Compilation finishes in a reasonable amount of time.
Comment 1 Matt McCutchen 2010-05-31 23:59:41 EDT
Created attachment 418454 [details]
Backtrace of cc1

I got a backtrace, and the compiler seems to be stuck in the "variable tracking" pass.  Passing either -fno-var-tracking or -fno-var-tracking-assignments makes compilation finish in about 13 seconds.
Comment 2 Jakub Jelinek 2010-06-14 01:36:35 EDT
Should be fixed in gcc-4.4.4-8.fc13.
Comment 3 Matt McCutchen 2010-06-15 00:46:57 EDT
Please push an update to Fedora 13.
Comment 4 Matt McCutchen 2010-07-18 21:34:38 EDT
I would appreciate an update for Fedora 13.  If you don't wish to do that, the correct resolution is NEXTRELEASE as per https://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow .
Comment 5 Matt McCutchen 2010-07-18 21:36:57 EDT
Sorry, I didn't notice that an update had been pushed in the meantime.

Note You need to log in before you can comment on or make changes to this bug.