Bug 598348 - Kernel doesn't enable network if no monitor is attached on Mac mini
Summary: Kernel doesn't enable network if no monitor is attached on Mac mini
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager   
(Show other bugs)
Version: 13
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-01 06:59 UTC by Steve
Modified: 2010-06-29 07:52 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 07:52:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
outpu of: cat /var/log/messages | grep error (4.91 KB, application/octet-stream)
2010-06-01 06:59 UTC, Steve
no flags Details
complete syslog (59.06 KB, application/octet-stream)
2010-06-01 09:58 UTC, Steve
no flags Details

Description Steve 2010-06-01 06:59:08 UTC
Created attachment 418494 [details]
outpu of: cat /var/log/messages | grep error

Description of problem:
kernel doesn't enable network if no monitor is attached

Version-Release number of selected component (if applicable):
kernel doesn't enable network if no monitor is attached

How reproducible:
Always

Steps to Reproduce:
1. Install new kernel
2. Reboot without monitor (lcd/beamer/tft/crt)
3. Check net
  
Actual results:
kernel doesn't enable network if no monitor is attached

Expected results:
Network should be enabled when rebooting as in kernel-PAE-2.6.33.4-95.fc13.i686

Comment 1 Steve 2010-06-01 09:58:38 UTC
Created attachment 418569 [details]
complete syslog

Comment 2 Steve 2010-06-01 12:44:22 UTC
Sorry forgot:
kernel-PAE-2.6.33.5-112.fc13.i686

Comment 3 Steve 2010-06-01 19:35:07 UTC
I have not seen this before but this is on all kernels until now. Network will not start on Mac mini if there is no Monitor attached.

Comment 4 Steve 2010-06-01 19:36:49 UTC
Other Intel systems i have checked, the network will be enabled without a Monitor.

Comment 5 Dan Williams 2010-06-15 18:26:09 UTC
What are the contents of any /etc/sysconfig/network-scripts/ifcfg-* file?  If you have ONBOOT=no in there, that's a result of using the DVD installer, which does not enable networking by default since you didn't use the network to install from.  If so, change that to ONBOOT=yes and you'll get networking automatically brought up.

If you have no ifcfg-* files in /etc/sysconfig/network-scripts, then you don't have any networking configuration, and thus there's nothing to bring up.  Let me know!

Comment 6 Steve 2010-06-15 19:06:56 UTC
I have "ONBOOT=yes" in my ifcfg-eth0. The network doesn't start only if there is no monitor connected! If there is a monitor connected, the network starts.

Comment 7 Dan Williams 2010-06-28 21:27:05 UTC
Can you attach/paste the following for me when the problem occurs?

1) any /etc/sysconfig/network-scripts/ifcfg-* file
2) output of 'ifconfig -a'
3) /var/log/messages

thanks!

Comment 8 Steve 2010-06-29 07:52:46 UTC
I close this bug because i think this is an problem of the Mac itself. It will not start if no monitor is connected.


Note You need to log in before you can comment on or make changes to this bug.