Bug 598359 - virt-manager doesn't create logical volumes on the first attempt
virt-manager doesn't create logical volumes on the first attempt
Status: CLOSED DUPLICATE of bug 597519
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.0
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-01 04:02 EDT by Justin Clift
Modified: 2010-06-14 14:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-14 14:03:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manager --debug log, clearly showing the virt-manager problem. (7.04 KB, text/plain)
2010-06-01 04:02 EDT, Justin Clift
no flags Details
Screenshot 1 (30.97 KB, image/png)
2010-06-01 04:03 EDT, Justin Clift
no flags Details
Screenshot 2 (38.03 KB, image/png)
2010-06-01 04:04 EDT, Justin Clift
no flags Details
Screenshot 3 (12.23 KB, image/png)
2010-06-01 04:04 EDT, Justin Clift
no flags Details
Screenshot 4 (32.19 KB, image/png)
2010-06-01 04:05 EDT, Justin Clift
no flags Details
Screenshot 5 (37.84 KB, image/png)
2010-06-01 04:05 EDT, Justin Clift
no flags Details
Screenshot 6 (42.61 KB, image/png)
2010-06-01 04:06 EDT, Justin Clift
no flags Details
Screenshot 7 (38.03 KB, image/png)
2010-06-01 04:06 EDT, Justin Clift
no flags Details
Screenshot 8 (12.23 KB, image/png)
2010-06-01 04:06 EDT, Justin Clift
no flags Details
Screenshot 9 (45.88 KB, image/png)
2010-06-01 04:07 EDT, Justin Clift
no flags Details
Screenshot 10 (46.40 KB, image/png)
2010-06-01 04:07 EDT, Justin Clift
no flags Details
Screenshot 11 (48.50 KB, image/png)
2010-06-01 04:08 EDT, Justin Clift
no flags Details
The matching libvirtd log from this session. (333.69 KB, application/x-bzip2)
2010-06-01 04:09 EDT, Justin Clift
no flags Details
Ogg video of the error session, recorded with Gtk-RecordMyDesktop. Works with (at least) VLC media player. (4.82 MB, video/ogg)
2010-06-01 04:31 EDT, Justin Clift
no flags Details
virt-manager --debug log (6.48 KB, text/plain)
2010-06-01 23:38 EDT, Justin Clift
no flags Details
virt-manager --debug log, from the .virt-manager dir (7.21 KB, text/plain)
2010-06-01 23:39 EDT, Justin Clift
no flags Details
libvirtd --verbose log, from the same session as the new virt-manager --debug logs (77.71 KB, application/x-bzip2)
2010-06-01 23:41 EDT, Justin Clift
no flags Details

  None (edit)
Description Justin Clift 2010-06-01 04:02:11 EDT
Created attachment 418512 [details]
virt-manager --debug log, clearly showing the virt-manager problem.

Description of problem:

In RHEL 6 (and present git head), virt-manager doesn't create logical lvm volumes on the first attempt.

Instead it generates an error message (twice), and on the third attempt (no change to the details) the logical volume creation works and is usable.


Version-Release number of selected component (if applicable):

virt-manager-0.8.2-3.el6.noarch
(and also tried against virt-manager compiled against git head, 0.8.4+)


How reproducible:

Every time.


Steps to Reproduce:
1. Use storage pool creation wizard to create a new logical volume, using a disk device (/dev/sdc) that is not presently known to lvm.  (ie not in pvscan, etc).  Ensure the "Build Pool" option is checked.  This will fail with a misleading error claiming the source path hasn't been specified.

  Screenshots 1 - 4.


2. After the above error message, uncheck the "Build Pool" option, then try again.  This time it will fail with an error message saying the lvm group isn't found. (correct)

  Screenshots 5 & 6.


3. After this second error message, check the "Build Pool" option again.  The settings are now the same as in step 1.  Additionally, it's worth noting that in this point pvscan and vgscan show no evidence of the device or volume group being in existence.

   Now when the Finish button is clicked, the storage pool creation works.

   Screenshots 7 - 9.


Storage volumes can now be created, as evidenced by screenshots 10 & 11.


Actual results:

Error message occurs for the first two attempts at logical storage pool creation.  Storage pool creation works on the third attempt.


Expected results:

Storage pool creation to work on the first attempt.

Additional info:

Also attaching the virt-manager debug log for this session, and the libvirtd on the RHEL 6 server for this session.
Comment 1 Justin Clift 2010-06-01 04:03:40 EDT
Created attachment 418513 [details]
Screenshot 1
Comment 2 Justin Clift 2010-06-01 04:04:19 EDT
Created attachment 418514 [details]
Screenshot 2
Comment 3 Justin Clift 2010-06-01 04:04:38 EDT
Created attachment 418515 [details]
Screenshot 3
Comment 5 Justin Clift 2010-06-01 04:05:00 EDT
Created attachment 418517 [details]
Screenshot 4
Comment 6 Justin Clift 2010-06-01 04:05:20 EDT
Created attachment 418518 [details]
Screenshot 5
Comment 7 Justin Clift 2010-06-01 04:06:10 EDT
Created attachment 418519 [details]
Screenshot 6
Comment 8 Justin Clift 2010-06-01 04:06:29 EDT
Created attachment 418520 [details]
Screenshot 7
Comment 9 Justin Clift 2010-06-01 04:06:53 EDT
Created attachment 418521 [details]
Screenshot 8
Comment 10 Justin Clift 2010-06-01 04:07:17 EDT
Created attachment 418522 [details]
Screenshot 9
Comment 11 Justin Clift 2010-06-01 04:07:39 EDT
Created attachment 418525 [details]
Screenshot 10
Comment 12 Justin Clift 2010-06-01 04:08:02 EDT
Created attachment 418526 [details]
Screenshot 11
Comment 13 Justin Clift 2010-06-01 04:09:21 EDT
Created attachment 418527 [details]
The matching libvirtd log from this session.
Comment 14 Justin Clift 2010-06-01 04:31:34 EDT
Created attachment 418533 [details]
Ogg video of the error session, recorded with Gtk-RecordMyDesktop.  Works with (at least) VLC media player.
Comment 15 Cole Robinson 2010-06-01 13:30:37 EDT
Can you also provide the output of virt-manager --debug when reproducing? I'll try to reproduce myself.
Comment 16 Justin Clift 2010-06-01 23:38:34 EDT
Created attachment 418892 [details]
virt-manager --debug log

This is the capture of stdout and stderr, created with:

  # virt-manager --debug 2>&1 | tee virt-manager-debug.log
Comment 17 Justin Clift 2010-06-01 23:39:50 EDT
Created attachment 418893 [details]
virt-manager --debug log, from the .virt-manager dir

This is the virt-manager.log from the .virt-manager directory, created from running virt-manager --debug
Comment 18 Justin Clift 2010-06-01 23:41:00 EDT
Created attachment 418894 [details]
libvirtd --verbose log, from the same session as the new virt-manager --debug logs
Comment 19 Justin Clift 2010-06-01 23:44:55 EDT
Cole, if it's any use it's easy to give you remote access (root and X11 enabled) to the server with this problem.  (ie. ssh -Xl root somehost)
Comment 20 RHEL Product and Program Management 2010-06-07 11:55:57 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 21 Cole Robinson 2010-06-14 14:03:29 EDT
The main issue here is that pool build was broken for LVM and disk pools. There is another side issue in that LVM volume group enumeration is broken, which was making the wizard more confusing then it needed to be. Bug for that issue filed here:

https://bugzilla.redhat.com/show_bug.cgi?id=603864

Duping this to your disk pool bug, which is basically the same problem.

*** This bug has been marked as a duplicate of bug 597519 ***

Note You need to log in before you can comment on or make changes to this bug.