Bug 598364 - Unable to create VPN connection with nm-applet
Summary: Unable to create VPN connection with nm-applet
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy   
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-01 08:12 UTC by Benjamín Valero Espinosa
Modified: 2010-06-03 08:06 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-03 08:06:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The warning from SELinux on connecting (2.88 KB, application/octet-stream)
2010-06-02 09:02 UTC, Benjamín Valero Espinosa
no flags Details

Description Benjamín Valero Espinosa 2010-06-01 08:12:58 UTC
I am unable to connect to my work VPN, with Fedora 13 updated, with nm-applet. The version is 0.7.997-1. With the same configuration, I was able with Fedora 12.

A significant difference in my both systems is that now I have SELinux enabled. After reading [1], I have run as root '/usr/libexec/nm-openvpn-service' and then I can connect. Perhaps is it a problem of permissions? What kind of info can I add?


[1] http://live.gnome.org/NetworkManager/Debugging

Comment 1 Benjamín Valero Espinosa 2010-06-02 08:48:32 UTC
I have just updated to testing, with some packages related to SELinux and a a new version 0.8 for NetworkManager-openvpn, but it still doesn't work.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Benjamín Valero Espinosa 2010-06-02 09:02:14 UTC
I have set SELinux to "Permissive" and it works now. SELinux shows me a warning that I attach. It is similar to bug #564167, but in this case SELinux prevents access to the .CER certificate.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Benjamín Valero Espinosa 2010-06-02 09:02:55 UTC
Created attachment 418964 [details]
The warning from SELinux on connecting

Comment 4 Benjamín Valero Espinosa 2010-06-03 07:50:36 UTC
I am moving this to selinux-policy. It this is wrong, tell me please.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 5 Benjamín Valero Espinosa 2010-06-03 08:06:17 UTC
I am closing it because this bug was my fault. My home partition came from a system without SELinux. Running "restorecon -r /home" has done the trick.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.