Bug 598378 - Wrong anaconda-ks.cfg generated after installation
Wrong anaconda-ks.cfg generated after installation
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-01 05:12 EDT by Igor Zhang
Modified: 2010-06-02 11:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-02 11:25:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Zhang 2010-06-01 05:12:45 EDT
Description of problem:
Wrong anaconda-ks.cfg generated after installation

Version-Release number of selected component (if applicable):
RHEL-6/Beta-1/AP/x86_64

How reproducible:
Every time

Steps to Reproduce:
Install this distro on a beaker machine which has been configured using raid(like intel-s3e3144-03.rhts.eng.nay.redhat.com).
1.
2.
3.
  
Actual results:
Wrong anaconda-ks.cfg generated in the partition section:
#clearpart --all --drives=sda,sdb,sdc
#ignoredisk --only-use=sda,sdb,sdc
#raid /raid5test --fstype=ext4 --level=5 --device=md0 raid.None raid.None raid.None

#part /boot --fstype=ext4 --size=500
#part /opt --fstype=ext4 --size=20500
#part swap --size=20500

#part / --fstype=ext4 --size=20000
#part raid.None --size=2000
#part raid.None --size=2000
#part raid.None --size=2000

Expected results:
This section should be like its counterpart in /root/cobbler.ks:
clearpart --all --drives=sda,sdb,sdc
ignoredisk --only-use=sda,sdb,sdc
part /boot --fstype=ext4 --size=500
part / --fstype=ext4 --size=20000
part raid.1 --size=2000

part /opt --fstype=ext4 --size=20500
part raid.2 --size=2000

part swap --size=20500
part raid.3 --size=2000

raid /raid5test --fstype=ext4 --level=5 --device=md0 raid.1 raid.2 raid.3

Additional info:
[root@intel-s3e3144-03 ~]# fdisk  -l

Disk /dev/sda: 73.4 GB, 73407868928 bytes
255 heads, 63 sectors/track, 8924 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000bd552

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          64      512000   83  Linux
Partition 1 does not end on cylinder boundary.
/dev/sda2              64        2678    20992000   83  Linux
/dev/sda3            2678        5291    20992000   82  Linux swap / Solaris
/dev/sda4            5291        8925    29190348    5  Extended
/dev/sda5            5291        7841    20480000   83  Linux
/dev/sda6            7841        8096     2048000   fd  Linux raid autodetect
/dev/sda7            8096        8351     2048000   fd  Linux raid autodetect
/dev/sda8            8351        8606     2048000   fd  Linux raid autodetect

Disk /dev/sdb: 73.4 GB, 73407868928 bytes
255 heads, 63 sectors/track, 8924 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000cb233

   Device Boot      Start         End      Blocks   Id  System

Disk /dev/sdc: 73.4 GB, 73407868928 bytes
255 heads, 63 sectors/track, 8924 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00049054

   Device Boot      Start         End      Blocks   Id  System

Disk /dev/md0: 4193 MB, 4193255424 bytes
2 heads, 4 sectors/track, 1023744 cylinders
Units = cylinders of 8 * 512 = 4096 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 524288 bytes / 1048576 bytes
Disk identifier: 0x00000000

Disk /dev/md0 doesn't contain a valid partition table
[root@intel-s3e3144-03 ~]# mdadm -D /dev/md0 
/dev/md0:
        Version : 1.1
  Creation Time : Tue Jun  1 02:45:20 2010
     Raid Level : raid5
     Array Size : 4094976 (3.91 GiB 4.19 GB)
  Used Dev Size : 2047488 (1999.84 MiB 2096.63 MB)
   Raid Devices : 3
  Total Devices : 3
    Persistence : Superblock is persistent

  Intent Bitmap : Internal

    Update Time : Tue Jun  1 05:00:41 2010
          State : active
 Active Devices : 3
Working Devices : 3
 Failed Devices : 0
  Spare Devices : 0

         Layout : left-symmetric
     Chunk Size : 512K

           Name : 0
           UUID : fc11029d:bf4691aa:93785d14:840f6d57
         Events : 114

    Number   Major   Minor   RaidDevice State
       0       8        6        0      active sync   /dev/sda6
       1       8        7        1      active sync   /dev/sda7
       3       8        8        2      active sync   /dev/sda8
[root@intel-s3e3144-03 ~]# cat /proc/mdstat 
Personalities : [raid6] [raid5] [raid4] 
md0 : active raid5 sda6[0] sda8[3] sda7[1]
      4094976 blocks super 1.1 level 5, 512k chunk, algorithm 2 [3/3] [UUU]
      bitmap: 0/1 pages [0KB], 65536KB chunk

unused devices: <none>
Comment 2 Chris Lumens 2010-06-02 11:25:17 EDT
/root/anaconda-ks.cfg is really only meant as a guideline.  The partitioning section is commented out so you have to look at it and verify its correctness before using it.  The fact that you're getting None there is because nothing's providing a UUID for those devices.

Note You need to log in before you can comment on or make changes to this bug.