Bug 598456 - storing extended attributes for special files.
Summary: storing extended attributes for special files.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tar   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Ondrej Vasik
QA Contact: Martin Cermak
URL:
Whiteboard:
Keywords:
Depends On: 573147
Blocks: 653995
TreeView+ depends on / blocked
 
Reported: 2010-06-01 12:29 UTC by Ondrej Vasik
Modified: 2010-11-16 15:35 UTC (History)
5 users (show)

Fixed In Version: tar-1.23-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 573147
: 653995 (view as bug list)
Environment:
Last Closed: 2010-11-10 21:45:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ondrej Vasik 2010-06-01 12:29:53 UTC
+++ This bug was initially created as a clone of Bug #573147 +++

Created an attachment (id=399788)
patch to tar to store more xattrs

I discovered that tar (1.22) on Fedora 12 does not store extended attributes (such as SELinux file labels) for character, block, or fifo files.  The attached patch stores that information within PAX extended headers, just as a previous patch to tar stores extended attributes for files, directories, and links.

--- Additional comment from ovasik@redhat.com on 2010-03-15 07:14:03 EDT ---

Thanks for suggestion and patch. We (me and Kamil) will check if this patch covers all cases and is safe for rawhide inclusion.

--- Additional comment from ovasik@redhat.com on 2010-04-07 15:00:24 EDT ---

Seems to be safe. Built as tar-1.23-3.fc14, closing RAWHIDE. Will consider inclusion into next update of tar in already released Fedora's.

Comment 1 RHEL Product and Program Management 2010-06-01 12:35:48 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 5 Martin Cermak 2010-10-05 06:49:03 UTC
=> VERIFIED

Comment 6 releng-rhel@redhat.com 2010-11-10 21:45:56 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.