Bug 598483 - gdm-simple-greeter uses 100% CPU if password file is big
gdm-simple-greeter uses 100% CPU if password file is big
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdm (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: jmccann
desktop-bugs@redhat.com
: Rebase
: 598145 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-01 09:27 EDT by Matthias Schroder
Modified: 2015-01-14 18:25 EST (History)
5 users (show)

See Also:
Fixed In Version: gdm-2.30.4-2.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:27:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 620908 None None None Never

  None (edit)
Description Matthias Schroder 2010-06-01 09:27:03 EDT
Description of problem: When the password file is big, and disable_user_list is false, gdm-simple-greeter uses 100% CPU for several minutes after startup


Version-Release number of selected component (if applicable): 2.28.2-5.el6.x86_64


How reproducible: 100%


Steps to Reproduce:
1. Use large password file
2. boot machine
3. watch gdm-simple-greeter hogging CPU
  
Actual results: gdm-simple-greeter hogs CPU


Expected results: CPU available for useful things


Additional info: 

1) Setting disable_user_list to true (I had to search quite a bit to find that one) avoids the issue.

2) This could be related to https://bugzilla.redhat.com/show_bug.cgi?id=598145

3) Numbers: processing a ~22k password file takes 5 minutes :(
Comment 2 RHEL Product and Program Management 2010-06-07 12:07:47 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Ray Strode [halfline] 2010-06-11 09:58:26 EDT
Just an update here.

Jon has done considerable work making this quite fast upstream.
Comment 4 Ray Strode [halfline] 2010-06-11 10:30:44 EDT
We should rebase to pull this in.  Otherwise we're going to have a bunch of pointless patches in cvs that will make maintainability more difficult.  The gnome-2-30 branch is all minor bugfixes and translation updates.
Comment 5 Tomas Pelka 2010-06-16 02:54:42 EDT
Reproducer in #c0, giving qa_ack.
Comment 7 jmccann 2010-06-22 14:12:51 EDT
*** Bug 598145 has been marked as a duplicate of this bug. ***
Comment 8 Ray Strode [halfline] 2010-06-29 15:22:28 EDT
Should be good to go.
Comment 10 Matthias Schroder 2010-07-16 09:49:07 EDT
In beta 2 the time it takes for the simple-greeter is ok now. But the gdm-user-switch-applet still needs 1:45, and during that time I don't get the gnome-panel. I admit that the time has decreased significantly, but it is still quite long. And together with https://bugzilla.redhat.com/show_bug.cgi?id=610233 this becomes painful...
Comment 11 jmccann 2010-07-16 10:31:06 EDT
Please file a new bug for that.  Can you attach gdb to the user switch applet during this time and interrupt it a few times to see where it is spending time?  Thanks.
Comment 12 Radek Lat 2010-08-17 07:18:01 EDT
Tested with >40k password file on gdm-2.30.4-21.el6.x86_64. No CPU hogging. Moving to VERIFIED.
Comment 13 releng-rhel@redhat.com 2010-11-10 15:27:44 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.