Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 598525 - bkr workflow-simple --package not working
bkr workflow-simple --package not working
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: command line (Show other bugs)
0.5
All Linux
high Severity high (vote)
: ---
: ---
Assigned To: Bill Peck
:
: 606705 (view as bug list)
Depends On:
Blocks: 583014 593365
  Show dependency treegraph
 
Reported: 2010-06-01 10:57 EDT by David Kutálek
Modified: 2010-06-29 10:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 10:18:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kutálek 2010-06-01 10:57:15 EDT
Description of problem:

When trying to submit all tasks for given package, beaker gives me an error:

[dkutalek@timothy upstream-testsuite]$ bkr  workflow-simple --dryrun --arch=i386 --arch=x86_64 --arch=s390x --arch=ppc64 --distro=RHEL6.0-20100527.2 --variant=server --package=gawk
Exception: bkr.server.bexceptions.BX:'Invalid Package : gawk'

There are two tasks loaded into beaker for package gawk:
https://beaker.engineering.redhat.com/tasks/3025
https://beaker.engineering.redhat.com/tasks/3026

Version-Release number of selected component (if applicable):
beaker-client-0.5.32-2.el6.noarch

How reproducible:
Always for me.

Steps to Reproduce:
upstream-testsuite]$ bkr  workflow-simple --dryrun --arch=i386 --arch=x86_64 --arch=s390x --arch=ppc64 --distro=RHEL6.0-20100527.2 --variant=server --package=gawk

Actual results:
Exception: bkr.server.bexceptions.BX:'Invalid Package : gawk'


Expected results:
Scheduling a job...

Additional info:
Comment 2 David Kovalsky 2010-06-09 07:03:19 EDT
Raising priority to reflect reality. Low prio && blocker don't make sense. 

I agree this should be a blocker, same as 583014 is.
Comment 3 Ales Zelinka 2010-06-18 09:37:32 EDT
Bill, can you take a look at this? It's been proposed for a blocker for some time. Compared to how swiftly you usually process this kind of bugs, I'm afraid it might have fallen through the cracks. Thanks
Comment 4 Bill Peck 2010-06-18 09:41:43 EDT
Hi Ales,

I'm looking at this Today.  I consider this to be the next highest priority bug.
Comment 5 Bill Peck 2010-06-22 09:33:50 EDT
*** Bug 606705 has been marked as a duplicate of this bug. ***
Comment 6 Bill Peck 2010-06-22 15:57:41 EDT
Fixed in git. Will go out in Tomorrows upgrade.
Comment 7 David Kutálek 2010-06-28 04:17:41 EDT
Works for me.

Note You need to log in before you can comment on or make changes to this bug.