Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 598582 - [abrt] crash in writerfilter::ooxml::OOXMLFactory::createFastChildContextFromStart
[abrt] crash in writerfilter::ooxml::OOXMLFactory::createFastChildContextFrom...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:3326f0515b3a4e88bac48cf77f8...
:
: 588792 600063 601359 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-01 12:39 EDT by Vitor Siqueira
Modified: 2010-06-08 09:25 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-08 09:25:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (246.66 KB, text/plain)
2010-06-01 12:39 EDT, Vitor Siqueira
no flags Details
File causing crash (163.70 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2010-06-01 15:37 EDT, Vitor Siqueira
no flags Details
Modified version of original file with the images that cause the crash (134.78 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2010-06-01 16:20 EDT, Vitor Siqueira
no flags Details
Modified version of original files with texts only (48.43 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2010-06-01 16:21 EDT, Vitor Siqueira
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 112027 None None None Never

  None (edit)
Description Vitor Siqueira 2010-06-01 12:39:23 EDT
abrt 1.1.0 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/broffice.org3/program/swriter.bin -writer file:///home/vitor/%C3%81rea%20de%20Trabalho/Trabalho%20Final%20V1.docx
component: openoffice.org
crash_function: writerfilter::ooxml::OOXMLFactory::createFastChildContextFromStart
executable: /usr/lib64/broffice.org3/program/swriter.bin
global_uuid: 3326f0515b3a4e88bac48cf77f82dfd989890483
kernel: 2.6.33.4-95.fc13.x86_64
package: broffice.org-writer-1:3.2.0-12.17.fc13
rating: 4
reason: Process /usr/lib64/broffice.org3/program/swriter.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. Just attempt to open any Microsoft Office Word 2007 document 
2.
3.
Comment 1 Vitor Siqueira 2010-06-01 12:39:34 EDT
Created attachment 418726 [details]
File: backtrace
Comment 2 Caolan McNamara 2010-06-01 13:08:25 EDT
*** Bug 588792 has been marked as a duplicate of this bug. ***
Comment 3 Caolan McNamara 2010-06-01 13:08:59 EDT
It doesn't crash on every .docx, can you attach a specific one that does crash
Comment 4 Vitor Siqueira 2010-06-01 15:37:10 EDT
Created attachment 418786 [details]
File causing crash

Attaching file that is causing the crash being reported
Comment 5 Vitor Siqueira 2010-06-01 16:20:34 EDT
Created attachment 418804 [details]
Modified version of original file with the images that cause the crash

An additional information: this bug probably occurs when there are images embedded in the document.

By using Microsoft Office 2007, I created two different versions of the original file that was causing the bug: one version with text only (occurs no crashes) and another with the images only (occurs same issue)
Comment 6 Vitor Siqueira 2010-06-01 16:21:27 EDT
Created attachment 418805 [details]
Modified version of original files with texts only
Comment 7 Caolan McNamara 2010-06-02 04:51:13 EDT
Reproducible, recurses to death
Comment 8 Caolan McNamara 2010-06-02 06:04:52 EDT
Looks like this happens on any unknown token, fix checked in and submitted upstream. Will be in >= 3.2.0-12.24
Comment 9 David Tardon 2010-06-04 01:03:34 EDT
*** Bug 600063 has been marked as a duplicate of this bug. ***
Comment 10 Gábor 2010-06-06 04:13:37 EDT
Package: openoffice.org-writer-1:3.2.0-12.23.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. open .docx document
2.
3.
Comment 11 David Tardon 2010-06-07 23:58:51 EDT
*** Bug 601359 has been marked as a duplicate of this bug. ***
Comment 12 Caolan McNamara 2010-06-08 09:25:36 EDT
Should be good in 3.2.0-12.24.f13

Note You need to log in before you can comment on or make changes to this bug.