Bug 59861 - DOS client app reporting read/write errors against samba share
DOS client app reporting read/write errors against samba share
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-13 18:16 EST by Scott Feldman
Modified: 2007-04-18 12:40 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-05 13:02:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Detailed description (951 bytes, text/plain)
2002-02-13 18:39 EST, Scott Feldman
no flags Details

  None (edit)
Description Scott Feldman 2002-02-13 18:16:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
DOS test application running on Windows 2K fails when writing to share mounted 
to Linux server using Samba.  The application writes and reads/compares a 
large 10Mbyte file to and from the server.  A full description is attached.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set two Win2K clients systems up to connect to the Linux share over SMB.
2. Run a DOS application that repeatably writes a large file (10MBytes) to the 
share and reads the file back comparing the file with the original.
3. On both of the Windows clients, explore the share with Explorer, and 
repeatable hit F5 to refresh the share contents while the DOS application is 
running.

	

Actual Results:  After a couple of minutes, one or both of the clients will 
report a delayed-write error.  This event will be logged in the event logger.  
Also, the server Samba log file for the client will report a read_data error.  
See attached full description for more information.

Expected Results:  Clients should not experience write errors.

Additional info:
Comment 1 Scott Feldman 2002-02-13 18:39:13 EST
Created attachment 45619 [details]
Detailed description
Comment 2 Scott Feldman 2002-02-13 21:47:31 EST
Continued testing with non-Linux server in same environment:
   Windows 2000: no client errors
   OpenUnix8 w/ Samba 2.2.3a: no client errors.
Comment 3 Trond Eivind Glomsrxd 2002-02-14 16:09:25 EST
Please test the 2.2.3a rpms available from http://people.redhat.com/teg/samba/
Comment 4 Trond Eivind Glomsrxd 2002-02-14 16:10:52 EST
I see that 2.2.3a is mentioned in the "detailed description", but not mentioned
otherwise - did it help?
Comment 5 Scott Feldman 2002-02-15 12:39:34 EST
We tried 2.2.3a from samba.org on RH 7.2 and we get the same failure.  Can we 
assume the tha RH 2.2.3a rpm is the same as what's available on samba.org?
Comment 6 Trond Eivind Glomsrxd 2002-02-15 12:41:28 EST
There shouldn't be code differences, no. Compiler flags and version, perhaps,
but not more than that.
Comment 7 Scott Feldman 2002-02-15 15:08:03 EST
Continued testing w/ Linux servers in same environment:
    RH 7.1 w/ Samba 2.0.7-36: passed, no client errors
    RH 7.1 w/ Samba 2.2.2 (from samba.org): failed w/ usual client errors
Comment 8 Scott Feldman 2002-02-16 13:11:35 EST
Continued testing w/ different Samba versions:
    2.0.8   PASS
    2.0.9   PASS
    2.2.0   FAIL
    2.2.0a  FAIL
    2.2.1   FAIL

This problem seems to have been introduced between 2.0.9 and 2.2.0.
Comment 9 Andrew Bartlett 2002-03-24 04:49:11 EST
Can you recheck with current Samba 2.2 CVS (pserver.samba.org)?  If this fails,
can you raise this on samba-technical@samba.org - it would be particuarly useful
if you can post a link to the test application.

Comment 10 Michael E Brown 2002-03-26 14:51:49 EST
Intel, Can you please attach copies of your testing scripts to this bugzilla, or
post a link to where they can be downloaded from?
Comment 11 Chris Sherwood 2002-04-12 03:47:00 EDT
I am experiencing the same issue using RH7.2 / Samba 2.2.1a upgraded to 2.2.3a 
on a Dell 1550.  The RH box is being accessed by W2K IIS 5.0 web servers (I 
know).  The only difference is that instead of a single large file, the IIS 
servers are constantly accessing many (upwards of 40,000 per dir) smaller files 
ranging from 10k to about 2Mb (all PDF's).  Have there been any updates or 
fixes to this bug as of yet?
Comment 12 Prasad M 2002-04-19 17:27:00 EDT
We are seeing similar failure running X-copy test from Windows clients, the 
server is IA64 box with Redhat 7.2 (64-bit).

The x-copy test is a simple batch file copies and comapre files from mounted 
drive (Linux box) using samba to local drives (Windows box).

Comment 13 Scott Feldman 2002-04-23 16:05:43 EDT
Thanks to some great help from the Samba folks, the original issue sighted 
appears to have been fixed with the latest Samba.  We verified the clients do 
not experience errors using the tip-of-tree from samba.org (pull on SAMBA_2_2 
and HEAD branches).

Jeremy @ samba.org provided the fix with this explaination: "I fixed an issue 
where an ill-timed signal could cause a socket read to return with -1 and 
errno = EINTR".

Would the other two submitters (csherwood, maribasavaih) please verify that 
this latest samba addresses their issues as well, and update this Bug so we 
can get closure on this issue.  Thanks.
Comment 14 Chris Sherwood 2002-06-05 13:02:35 EDT
We have been running on v2.2.5pre since it came out (about 4-6 weeks), and we 
have not seen this problem come back...looks to be fixed as far as I can tell.
Comment 15 Trond Eivind Glomsrxd 2002-07-24 19:26:14 EDT
samba-2.2.5-6 is currently in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.