Bug 598665 - SELinux is preventing /usr/bin/kdm "read" access on .dmrc.
Summary: SELinux is preventing /usr/bin/kdm "read" access on .dmrc.
Status: CLOSED DUPLICATE of bug 598664
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
(Show other bugs)
Version: 13
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:e72fa4c71c6...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-01 19:58 UTC by Elad Mizrahi
Modified: 2010-06-01 20:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-01 20:46:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Elad Mizrahi 2010-06-01 19:58:49 UTC
Summary:

SELinux is preventing /usr/bin/kdm "read" access on .dmrc.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by kdm. It is not expected that this access is
required by kdm and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                .dmrc [ file ]
Source                        kdm
Source Path                   /usr/bin/kdm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           kdm-4.4.3-1.fc13.1
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-21.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.4-95.fc13.i686 #1 SMP Thu
                              May 13 05:55:24 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Mon 31 May 2010 11:04:13 PM IDT
Last Seen                     Mon 31 May 2010 11:04:13 PM IDT
Local ID                      b0901a92-32f3-48f7-9c85-c90654b91697
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1275336253.806:33270): avc:  denied  { read } for  pid=28825 comm="kdm" name=".dmrc" dev=dm-0 ino=7910 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1275336253.806:33270): arch=40000003 syscall=5 success=yes exit=3 a0=8949990 a1=8800 a2=0 a3=0 items=0 ppid=28811 pid=28825 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="kdm" exe="/usr/bin/kdm" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,kdm,xdm_t,admin_home_t,file,read
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t admin_home_t:file read;

Comment 1 Daniel Walsh 2010-06-01 20:46:43 UTC

*** This bug has been marked as a duplicate of bug 598664 ***


Note You need to log in before you can comment on or make changes to this bug.