Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 598689 - token retransmissions reset last_aru to current token's aru.
token retransmissions reset last_aru to current token's aru.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openais (Show other bugs)
5.5
All Linux
low Severity high
: rc
: ---
Assigned To: Steven Dake
Cluster QE
: ZStream
: 490856 617644 (view as bug list)
Depends On: 598680
Blocks: 601076 601077
  Show dependency treegraph
 
Reported: 2010-06-01 16:40 EDT by Steven Dake
Modified: 2018-11-14 14:16 EST (History)
7 users (show)

See Also:
Fixed In Version: openais-0.80.6-24.el5
Doc Type: Bug Fix
Doc Text:
An internal protocol variable was set on retransmission when it should only have been set on the first transmission. With this update, the aforementioned variable is only set on the first transmission.
Story Points: ---
Clone Of: 598680
Environment:
Last Closed: 2011-01-13 18:56:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
whitetank revision 2144 (545 bytes, patch)
2010-06-01 16:43 EDT, Steven Dake
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0100 normal SHIPPED_LIVE openais bug fix update 2011-01-12 12:21:13 EST

  None (edit)
Description Steven Dake 2010-06-01 16:40:16 EDT
+++ This bug was initially created as a clone of Bug #598680 +++

Description of problem:
token retransmissions reset last_aru to current token's aru.

Version-Release number of selected component (if applicable):
corosync-1.2.3-1.el6

How reproducible:
not sure how to generate a fault

Could be a serious problem in lossy network environments.

Totem spec is clear:

reject retransmitted tokens
if token.aru = aru in token on last rotation ... do some logic

Here is how the current code works:

last_aru = instance->my_last_aru;
instance->my_last_aru = token->aru;
reject retransmitted tokens
if token.aru = aru in token on last rotation ... do some logic

The issue is last_aru will be set to token->aru when a token retransmission occurs before a new token arrives.

This results in the "do some logic" part happening more often then it should.

--- Additional comment from pm-rhel@redhat.com on 2010-06-01 16:26:08 EDT ---

This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

--- Additional comment from sdake@redhat.com on 2010-06-01 16:37:34 EDT ---

Created an attachment (id=418808)
trunk revision 2917
Comment 1 Steven Dake 2010-06-01 16:43:54 EDT
Created attachment 418815 [details]
whitetank revision 2144
Comment 9 Douglas Silas 2011-01-11 18:15:00 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
An internal protocol variable was set on retransmission when it should only have been set on the first transmission. With this update, the aforementioned variable is only set on the first transmission.
Comment 11 errata-xmlrpc 2011-01-13 18:56:59 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0100.html
Comment 12 Jan Friesse 2011-05-03 10:59:08 EDT
*** Bug 490856 has been marked as a duplicate of this bug. ***
Comment 13 Steven Dake 2011-05-23 10:51:52 EDT
*** Bug 617644 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.