Bug 598835 - Segmentation fault when calling `... | rngd -f -r /dev/stdin`
Segmentation fault when calling `... | rngd -f -r /dev/stdin`
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rng-tools (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jeff Garzik
:
: 598837 598838 598841 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-02 03:04 EDT by Jan Hutař
Modified: 2016-01-14 06:04 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-08 01:15:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2010-06-02 03:04:44 EDT
Description of problem:
I'm trying to increase entropy on my system using:

https://bmearns.net/wwk/view//dev/random

but rngd segfaults instead (in both normal and FIPS mode).


Version-Release number of selected component (if applicable):
rng-tools-2-6.el6.i686


How reproducible:
always


Steps to Reproduce:
1. # cat /proc/sys/kernel/random/entropy_avail
2. # cat /proc/1/exe | gzip -c | rngtest -p | rngd -f -r /dev/stdin


Actual results:
Segmentation fault (core dumped)


Expected results:
Should increase entropy


Additional info:
Same command works on my local workstation with F12 using rng-utils-2.0-4.fc12.x86_64

Backtrace is short:
#0  0x00000002 in ?? ()
#1  0x08048a76 in do_loop (random_step=64, poll_timeout=60) at rngd.c:217
#2  0x08048c2f in main (argc=4, argv=0xbfefa1c4) at rngd.c:262
Comment 6 Bill Nottingham 2010-06-02 15:18:39 EDT
*** Bug 598837 has been marked as a duplicate of this bug. ***
Comment 7 Bill Nottingham 2010-06-02 15:18:49 EDT
*** Bug 598838 has been marked as a duplicate of this bug. ***
Comment 8 Bill Nottingham 2010-06-02 15:19:04 EDT
*** Bug 598841 has been marked as a duplicate of this bug. ***
Comment 9 Bill Nottingham 2010-06-02 15:41:40 EDT
Is this fixed with the fixes for bug 597221?
Comment 10 Jeff Garzik 2010-06-03 02:04:37 EDT
It seems likely, yes.
Comment 11 RHEL Product and Program Management 2010-06-07 12:20:53 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Note You need to log in before you can comment on or make changes to this bug.