Bug 598869 - hanging reservation without any reason
hanging reservation without any reason
Status: CLOSED NOTABUG
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.5
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-02 04:59 EDT by Jan Kratochvil
Modified: 2010-06-02 09:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-02 09:06:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2010-06-02 04:59:52 EDT
Description of problem:
I just want some latest RHEL-6 snapshot.  Unaware where to get some commandline client so I switched to a browser and went to the web.

Submitted first reservation, waited till its 1523 finish to find out I have accidentally chosen from those thousands of distros a too old one.  Cancelled.

Submitted a second reservation more carefully - 1531 - but it is now hanging for an hour in state "Queued" without any reason why is it hanging.

Version-Release number of selected component (if applicable):
Version - 0.5.40

How reproducible:
Always.

Steps to Reproduce:
Goal: Allocate latest RHEL-6 snapshot.

Actual results:
Lost one and half hour of my worktime.

Expected results:
Reservation in 5 seconds from a pool of automatically preinstalled machine pool.

Additional info:
Cannot use StableSystems as GDB testsuites occasionally crash the machine.
Comment 1 Bill Peck 2010-06-02 09:06:55 EDT
We have a bz for sorting the distros in the reserve workflow so you see the newest first.

If you second job stayed in the Queued state it was because there really was no machine available that you have access to.  I see that its installed now.

Once we stabilize and move completely off of legacy rhts we will be looking into using virt infrastructure to generate machines in a short time.

Note You need to log in before you can comment on or make changes to this bug.