Bug 59891 - xscreensaver needs gnome stuff
xscreensaver needs gnome stuff
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: xscreensaver (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-14 10:56 EST by Sammy
Modified: 2014-03-16 22:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-27 02:46:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2002-02-14 10:56:36 EST
xscreensaver-4.0-1 requires a bunch of gnome libraries....why?
If this is neccesary than we need a -kde and -gnome versions
because I am using kde and do not want to install all  the
gnome stuff.
Comment 1 Alexei Podtelezhnikov 2002-02-14 16:39:02 EST
Building xscreensaver-4.00-1.src.rpm also requires /usr/bin/gnome-config.
What happens is that gnome takes over xscreensaver here, which is a 
perfectly fine independent piece. I use it with KDE and I'm happy.

Please, please, revert it, let gnome require xscreensaver, not vice versa.
It's gnome what uses it, not vice versa. Don't break the logic.
Comment 2 Alexei Podtelezhnikov 2002-02-26 16:18:23 EST
Now, I think it's fine to switch from motif to gtk in xscreensaver-demo. 
Both are not kdelibs, so shouldn't matter to me and other kde users. 

How about spliting the package into xscreensaver and xscreensaver-demo?
First should contain hacks and demon, second - GUI config-tool. 
This, btw, will better fit Gnome too, since it also uses it's own control 
center to control xscreensaver.
Comment 3 Alexei Podtelezhnikov 2002-05-29 23:50:37 EDT
Please, please, please!

Split xscreensaver into at least two packages:

xscreensaver (or xscreensaver-common):
   - providing deamon itself, xscreensaver-control and executable modules 
   - requiring only on XFree86, and other low level stuff.

xscreensaver-gnome (or xscreensaver-demo):
   - providing config programm xscreensaver-demo based on GTK, 
     and control-center hooks
   - requiring gnome stuff and xscreensaver

and later (hopefully some day) we'll have
xscreensaver-kde:

I love kde, but honestly their screensavers suck. Since 7.3 I depend on gnome.
This solution will make everybody happy.
Comment 4 Alexei Podtelezhnikov 2002-05-30 00:02:38 EDT
and finally this is how kde developers make xscreensavers work for them
without any patching!

http://lists.kde.org/?l=kde-devel&m=101787059008234&w=2

Just enother point for xscreensaver independence. I'll open RFE for 
bero@redhat.com.

Comment 5 Jamie Zawinski 2002-07-27 02:46:52 EDT
xscreensaver depends on gnome in order to make xscreensaver-command funtion as
the gnome control-center configurator (it needs to link against Gnome's
libcapplet to do this) in Gnome 1.x.

In a Gnome 2.x world, xscreensaver only depends on Gtk 2.x, not on Gnome 2.x.

So this problem (the unwanted dependence on Gnome) will go away once Red Hat
updates their distro (and their xscreensaver build) to Gtk 2.x / Gnome 2.x.

(xscreensaver only supports Gnome / Gtk 2.x as of xscreensaver 4.x, which I
don't think RH has yet shipped with any release.)
Comment 6 Bill Nottingham 2002-07-31 00:53:35 EDT
The current version in rawhide (4.05-x) only requires gtk-2.x, as jwz mentioned.

Note You need to log in before you can comment on or make changes to this bug.