Bug 598924 - ypxfr spits out invalid pointer errors
ypxfr spits out invalid pointer errors
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ypserv (Show other bugs)
4.7
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Karel Klíč
qe-baseos-daemons
: ZStream
Depends On: 497584
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-02 06:59 EDT by RHEL Product and Program Management
Modified: 2011-01-05 01:33 EST (History)
10 users (show)

See Also:
Fixed In Version: ypserv-2.13-19.el4_8.2
Doc Type: Bug Fix
Doc Text:
Due to an incorrect handling of pointers, using ypinit to build the S390x NIS slave server against the Solaris 10 UltraSPARC NIS master resulted in the following error: *** glibc detected *** free(): invalid pointer: 0x00000200001a1000 *** With this update, the slave server no longer stops responding when the invalid pointer is freed, and ypinit builds a set of administrative system maps as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-20 05:08:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RHEL Product and Program Management 2010-06-02 06:59:15 EDT
This bug has been copied from bug #497584 and has been proposed
to be backported to 4.8 z-stream (EUS).
Comment 3 Jaromir Hradilek 2010-06-25 08:13:19 EDT
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
Due to an incorrect handling of pointers, using ypinit to build the S390x NIS slave server against the Solaris 10 UltraSPARC NIS master resulted in the following error:

  *** glibc detected *** free(): invalid pointer: 0x00000200001a1000 ***

With this update, the slave server no longer stops responding when the invalid pointer is freed, and ypinit builds a set of administrative system maps as expected.
Comment 9 errata-xmlrpc 2010-07-20 05:08:19 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0540.html

Note You need to log in before you can comment on or make changes to this bug.