Bug 598938 - Boot menu and disk testing app not translated
Boot menu and disk testing app not translated
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 619410 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-02 07:23 EDT by Zoltan Hoppar
Modified: 2012-10-05 15:57 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-05 15:57:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zoltan Hoppar 2010-06-02 07:23:39 EDT
Description of problem:
If you are booting in to Fedora first time then this two part of the software doesn't available for users just in english.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot into an Live Fedora
2. The first boot menu, and the disk testing application c doesn't provide multiple translations
  
Actual results:
Just plain english

Expected results:
Possibly translations

Additional info:
Could we get POT files into Transifex?
Comment 1 Chris Lumens 2010-06-09 09:35:26 EDT
Can you attach pictures of the screens in question?
Comment 2 Zoltan Hoppar 2010-07-28 00:58:06 EDT
Not needed, because this is part of the Media check. Sorry for the bad expression. (This is still the same program what I have found in google from older FCore: http://www.labtestproject.com/files/linuse/images/f4-big/003-testing-start.png) So, when you're entering to test the written disk is THAT UI is only english. Is it possible to translate it, and use it as could be red by anybody? Also may be this could include also the very first grub boot menu too? I know this is tiny little pieces of the distribution, but this could make it much nearer to the users. What do you think? Could we have an POT file to these parts?
Or is any way to trigger to another language this part?
Comment 3 Bug Zapper 2010-07-30 07:47:04 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Chris Lumens 2010-08-20 14:23:03 EDT
*** Bug 619410 has been marked as a duplicate of this bug. ***
Comment 5 Radek Vykydal 2010-08-23 11:11:19 EDT
This is not an isomd5sum issue. It happens because if we detect media we intentionally skip lang and keyboard selection step:

commit c87a634289ebeaeba54cd9d41ce9f11eaefe5c08
Author: Chris Lumens <clumens@redhat.com>
Date:   Wed Aug 6 11:33:26 2008 -0400

    If we're booting off the boot.iso, don't prompt for lang or kbd (#457595).

Note that this bz is for Live, which is probably ok, but bug #619410 is not.
Comment 6 Jens Petersen 2012-06-28 05:12:59 EDT
(In reply to comment #5)
> This is not an isomd5sum issue. It happens because if we detect media we
> intentionally skip lang and keyboard selection step:

At the beginning of stage2 yes - but this is a stage1 bug.

I think I saw some translation of F17 grub before release
but I think the framebuffer usage was reverted before the final release?
Maybe it will return for F18?

Anyway moving to F17.
Comment 7 Vladimir Serbinenko 2012-06-28 08:39:52 EDT
AFAIK the only thing which was reverted is using theme. But international support shoulf still be there.
Comment 8 Chris Lumens 2012-10-05 15:57:12 EDT
This interface is no longer in anaconda.

Note You need to log in before you can comment on or make changes to this bug.